Unsafe default allows for cross-site scripting attacks in KNIME Server and KNIME Business Hub
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
An unsafe default configuration in KNIME Analytics Platform before 5.2.0 allows for a cross-site scripting attack. When KNIME Analytics Platform is used as an executor for either KNIME Server or KNIME Business Hub several JavaScript-based view nodes do not sanitize the data that is displayed by default. If the data to be displayed contains JavaScript this code is executed in the browser and can perform any operations that the current user is allowed to perform silently. KNIME Analytics Platform already has configuration options with which sanitization of data can be actived, see https://docs.knime.com/latest/webportal_admin_guide/index.html#html-sanitization-webportal https://docs.knime.com/latest/webportal_admin_guide/index.html#html-sanitization-webportal . However, these are off by default which allows for cross-site scripting attacks. KNIME Analytics Platform 5.2.0 will enable sanitization by default. For all previous releases we recommend users to add the corresponding settings to the executor's knime.ini.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA KNIME Analytics Platform (KNIME) Fixed in 5.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5562
- 2026-10-03 Alias added: GHSA-4g9c-4jmr-xrqp
References
More Knime Analytics Platform vulnerabilities
- TI-2022-13425 In KNIME Analytics Platform below 4.6.0, the Windows installer sets improper filesystem permissions. CVSS 3.1HIGH 7.8
- TI-2022-22038 Opening workflows from untrusted resources may override arbitrary file system contents CVSS 3.1HIGH 7.0
- TI-2021-20428 KNIME Analytics Platform before 4.5.0 is vulnerable to XXE (external XML entity… CVSS 3.1MEDIUM 4.7
Sources
- CVE-2023-5562 · CVE Program
- CVE-2023-5562 · NVD
- FIRST EPSS
- GHSA-4g9c-4jmr-xrqp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences