Webpushr < 4.35.0 - Unauthenticated Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Web Push Notifications WordPress plugin before 4.35.0 does not prevent visitors on the site from changing some of the plugin options, some of which may be used to conduct Stored XSS attacks.
Why it matters now
EPSS 0.00426 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Web Push Notifications (Unknown): 4.35.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Web Push Notifications | before 4.35.0 | 4.35.0 | Patch available | CNA |
- Web Push Notifications VendorUnknown Affected before 4.35.0 Fixed in 4.35.0 Patch available CNA
Remediation
- Fix · CNA Web Push Notifications (Unknown) Fixed in 4.35.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5620
- 2026-10-03 Alias added: GHSA-vpf6-j6mv-p249
References
More webpushr Web Push Notifications vulnerabilities
- TI-2023-17517 WordPress Webpushr Plugin <= 4.34.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2023-5620 · CVE Program
- CVE-2023-5620 · NVD
- FIRST EPSS
- GHSA-vpf6-j6mv-p249 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences