Stored XSS vulnerability in Roundcube
Priority CRITICAL 86Exploited in the wildCWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Roundcube before 1.4.15, 1.5.x before 1.5.5, and 1.6.x before 1.6.4 allows stored XSS via an HTML e-mail message with a crafted SVG document because of program/lib/Roundcube/rcube_washtml.php behavior. This could allow a remote attacker to load arbitrary JavaScript code.
Why it matters now
Exploitation Active In CISA KEV since 2023-10-26CISA due date 2023-11-16
EPSS 0.76337 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Roundcubemail (Roundcube): 1.6.3, 1.5.4, 1.5.14 +3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Roundcube | Roundcubemail | 1.6.0 to before 1.6.3; 1.5.0 to before 1.5.4; 1.4.0 to before 1.5.14 | 1.6.3, 1.5.4, 1.5.14, 1.6.4, 1.5.5, 1.5.15 | Patch available | CNA |
- Roundcubemail VendorRoundcube Affected 1.6.0 to before 1.6.3; 1.5.0 to before 1.5.4; 1.4.0 to before 1.5.14 Fixed in 1.6.3, 1.5.4, 1.5.14, 1.6.4, 1.5.5, 1.5.15 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:roundcube:webmail:*:*:*:*:*:*:*:* | before 1.4.15; 1.5.0 to before 1.5.5; 1.6.0 to before 1.6.4 | Vulnerable | Roundcube |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* | 12.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
- cpe:2.3:a:roundcube:webmail:*:*:*:*:*:*:*:* Versions before 1.4.15; 1.5.0 to before 1.5.5; 1.6.0 to before 1.6.4 Vulnerable ·Roundcube
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* Versions 12.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Roundcubemail (Roundcube) Fixed in 1.6.3, 1.5.4, 1.5.14, 1.6.4, 1.5.5, 1.5.15
Vendor assessments
Timeline
- 2023-10-26 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2023-5631
- 2026-10-03 Alias added: GHSA-qf8f-27cp-gw76
References
Patch 3
Advisory 4
Other 7
- https://github.com/roundcube/roundcubemail/releases/tag/1.6.4
- https://github.com/roundcube/roundcubemail/releases/tag/1.5.5
- https://github.com/roundcube/roundcubemail/releases/tag/1.4.15
- https://roundcube.net/news/2023/10/16/security-update-1.6.4-released
- https://roundcube.net/news/2023/10/16/security-updates-1.5.5-and-1.4.15
- https://www.debian.org/security/2023/dsa-5531
- https://lists.fedoraproject.org/archives/list/[email protected]/message/LK67Q46OIEGJCRQUBHKLH3IIJTBNGGX4/
More Roundcube Webmail vulnerabilities
- TI-2025-31204 Deserialization of untrusted data in Roundcube Webmail KEVCVSS 3.1CRITICAL 9.9
- TI-2021-19778 Roundcube before 1.3.17 and 1.4.x before 1.4.12 is prone to a potential SQL injection via search or search_params. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10051 rcube_image.php in Roundcube Webmail before 1.4.4 allows attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2024-28025 A Cross-Site Scripting vulnerability in Roundcube through 1.5.7 and 1.6.x through 1.6.7… KEVCVSS 3.1CRITICAL 9.3
- TI-2017-12250 Roundcube Webmail before 1.1.10, 1.2.x before 1.2.7, and 1.3.x before 1.3.3 allows… KEVCVSS 3.1HIGH 7.8
- TI-2025-41994 Cross-site scripting in Roundcube Webmail KEVCVSS 3.1HIGH 7.2
Sources
- CVE-2023-5631 · CVE Program
- CVE-2023-5631 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-qf8f-27cp-gw76 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-5631 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences