Read the docs
TI-2023-05222 Aliases CVE-2023-5679GHSA-v5qp-mx94-j49v

Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution

Priority LOW 35CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-617.

Summary

A bad interaction between DNS64 and serve-stale may cause `named` to crash with an assertion failure during recursive resolution, when both of these features are enabled. This issue affects BIND 9 versions 9.16.12 through 9.16.45, 9.18.0 through 9.18.21, 9.19.0 through 9.19.19, 9.16.12-S1 through 9.16.45-S1, and 9.18.11-S1 through 9.18.21-S1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01276 70th percentileScored 2026-11-07
Fix Fixed Red Hat: 7 advisories

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 99.16.12 – 9.16.45; 9.18.0 – 9.18.21; 9.19.0 – 9.19.19; 9.16.12-S1 – 9.16.45-S1; 9.18.11-S1 – 9.18.21-S1—No fix listedCNA
  • BIND 9 VendorISC Affected 9.16.12 – 9.16.45; 9.18.0 – 9.18.21; 9.19.0 – 9.19.19; 9.16.12-S1 – 9.16.45-S1; 9.18.11-S1 – 9.18.21-S1 Fixed in — No fix listed CNA

CPE configurations NVD · 15

CPEVersionsRoleVendor
cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:*not specified by NVDVulnerableNetApp
cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:*38VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:*39VulnerableFedoraproject
cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:*9.16.12 – 9.16.45; 9.18.0 – 9.18.21; 9.19.0 – 9.19.19VulnerableISC
cpe:2.3:a:isc:bind:9.16.12:s1:*:*:supported_preview:*:*:*9.16.12 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.13:s1:*:*:supported_preview:*:*:*9.16.13 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.14:s1:*:*:supported_preview:*:*:*9.16.14 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.21:s1:*:*:supported_preview:*:*:*9.16.21 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.32:s1:*:*:supported_preview:*:*:*9.16.32 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.36:s1:*:*:supported_preview:*:*:*9.16.36 s1VulnerableISC
  • cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
  • cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* Versions 9.16.12 – 9.16.45; 9.18.0 – 9.18.21; 9.19.0 – 9.19.19 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.12:s1:*:*:supported_preview:*:*:* Versions 9.16.12 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.13:s1:*:*:supported_preview:*:*:* Versions 9.16.13 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.14:s1:*:*:supported_preview:*:*:* Versions 9.16.14 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.21:s1:*:*:supported_preview:*:*:* Versions 9.16.21 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.32:s1:*:*:supported_preview:*:*:* Versions 9.16.32 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.36:s1:*:*:supported_preview:*:*:* Versions 9.16.36 s1 Vulnerable ·ISC
Show 5 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.16.43:s1:*:*:supported_preview:*:*:*9.16.43 s1VulnerableISC
cpe:2.3:a:isc:bind:9.16.45:s1:*:*:supported_preview:*:*:*9.16.45 s1VulnerableISC
cpe:2.3:a:isc:bind:9.18.11:s1:*:*:supported_preview:*:*:*9.18.11 s1VulnerableISC
cpe:2.3:a:isc:bind:9.18.18:s1:*:*:supported_preview:*:*:*9.18.18 s1VulnerableISC
cpe:2.3:a:isc:bind:9.18.21:s1:*:*:supported_preview:*:*:*9.18.21 s1VulnerableISC
  • cpe:2.3:a:isc:bind:9.16.43:s1:*:*:supported_preview:*:*:* Versions 9.16.43 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.16.45:s1:*:*:supported_preview:*:*:* Versions 9.16.45 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.18.11:s1:*:*:supported_preview:*:*:* Versions 9.18.11 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.18.18:s1:*:*:supported_preview:*:*:* Versions 9.18.18 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.18.21:s1:*:*:supported_preview:*:*:* Versions 9.18.21 s1 Vulnerable ·ISC

Remediation

Red Hat 7 advisories

  • RHSA-2024:2551 Released 2024-04-30 · Red Hat rating Important
    bind security update
    • Red Hat Enterprise Linux AppStream (v. 9) bind-32:9.16.23-18.el9_4.1, bind-chroot-32:9.16.23-18.el9_4.1, bind-dnssec-doc-32:9.16.23-18.el9_4.1 +6
    • Red Hat Enterprise Linux CRB (v. 9) bind-devel-32:9.16.23-18.el9_4.1, bind-doc-32:9.16.23-18.el9_4.1, bind-libs-32:9.16.23-18.el9_4.1
  • RHSA-2024:1803 Released 2024-04-15 · Red Hat rating Important
    bind and bind-dyndb-ldap security updates
    • Red Hat CodeReady Linux Builder EUS (v.9.2) bind-devel-32:9.16.23-11.el9_2.4, bind-doc-32:9.16.23-11.el9_2.4, bind-libs-32:9.16.23-11.el9_2.4
    • Red Hat Enterprise Linux AppStream EUS (v.9.2) bind-32:9.16.23-11.el9_2.4, bind-chroot-32:9.16.23-11.el9_2.4, bind-dnssec-doc-32:9.16.23-11.el9_2.4 +6
  • RHSA-2024:1800 Released 2024-04-15 · Red Hat rating Important
    bind and bind-dyndb-ldap security updates
    • Red Hat CodeReady Linux Builder EUS (v.9.0) bind-devel-32:9.16.23-1.el9_0.5, bind-libs-32:9.16.23-1.el9_0.5
    • Red Hat Enterprise Linux AppStream EUS (v.9.0) bind-32:9.16.23-1.el9_0.5, bind-chroot-32:9.16.23-1.el9_0.5, bind-dnssec-doc-32:9.16.23-1.el9_0.5 +6
Show 4 more Red Hat advisories
  • RHSA-2024:1789 Released 2024-04-11 · Red Hat rating Important
    bind security update
    • Red Hat CodeReady Linux Builder (v. 9) bind-devel-32:9.16.23-14.el9_3.4, bind-doc-32:9.16.23-14.el9_3.4, bind-libs-32:9.16.23-14.el9_3.4
    • Red Hat Enterprise Linux AppStream (v. 9) bind-32:9.16.23-14.el9_3.4, bind-chroot-32:9.16.23-14.el9_3.4, bind-dnssec-doc-32:9.16.23-14.el9_3.4 +6
  • RHSA-2024:1781 Released 2024-04-11 · Red Hat rating Important
    bind9.16 security update
    • Red Hat CodeReady Linux Builder (v. 8) bind9.16-devel-32:9.16.23-0.16.el8_9.2, bind9.16-doc-32:9.16.23-0.16.el8_9.2, bind9.16-libs-32:9.16.23-0.16.el8_9.2
    • Red Hat Enterprise Linux AppStream (v. 8) bind9.16-32:9.16.23-0.16.el8_9.2, bind9.16-chroot-32:9.16.23-0.16.el8_9.2, bind9.16-dnssec-utils-32:9.16.23-0.16.el8_9.2 +4
  • RHSA-2024:1648 Released 2024-04-02 · Red Hat rating Important
    bind9.16 security update
    • Red Hat CodeReady Linux Builder EUS (v.8.8) bind9.16-devel-32:9.16.23-0.14.el8_8.4, bind9.16-doc-32:9.16.23-0.14.el8_8.4, bind9.16-libs-32:9.16.23-0.14.el8_8.4
    • Red Hat Enterprise Linux AppStream EUS (v.8.8) bind9.16-32:9.16.23-0.14.el8_8.4, bind9.16-chroot-32:9.16.23-0.14.el8_8.4, bind9.16-dnssec-utils-32:9.16.23-0.14.el8_8.4 +4
  • RHSA-2024:1647 Released 2024-04-02 · Red Hat rating Important
    bind9.16 security update
    • Red Hat CodeReady Linux Builder EUS (v.8.6) bind9.16-devel-32:9.16.23-0.7.el8_6.5, bind9.16-dnssec-utils-32:9.16.23-0.7.el8_6.5, bind9.16-doc-32:9.16.23-0.7.el8_6.5 +2
    • Red Hat Enterprise Linux AppStream EUS (v.8.6) bind9.16-32:9.16.23-0.7.el8_6.5, bind9.16-chroot-32:9.16.23-0.7.el8_6.5, bind9.16-libs-32:9.16.23-0.7.el8_6.5 +2

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat CodeReady Linux Builder (v. 8)Fixed RHSA-2024:1781
Red Hat CodeReady Linux Builder (v. 9)Fixed RHSA-2024:1789
Red Hat CodeReady Linux Builder EUS (v.8.6)Fixed RHSA-2024:1647
Red Hat CodeReady Linux Builder EUS (v.8.8)Fixed RHSA-2024:1648
Red Hat CodeReady Linux Builder EUS (v.9.0)Fixed RHSA-2024:1800
Red Hat CodeReady Linux Builder EUS (v.9.2)Fixed RHSA-2024:1803
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2024:1781
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2024:1789, RHSA-2024:2551
Red Hat Enterprise Linux AppStream EUS (v.8.6)Fixed RHSA-2024:1647
Red Hat Enterprise Linux AppStream EUS (v.8.8)Fixed RHSA-2024:1648
Red Hat Enterprise Linux AppStream EUS (v.9.0)Fixed RHSA-2024:1800
Red Hat Enterprise Linux AppStream EUS (v.9.2)Fixed RHSA-2024:1803
Red Hat Enterprise Linux CRB (v. 9)Fixed RHSA-2024:2551
Not affected: 4 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5679
  2. 2026-10-03 Alias added: GHSA-v5qp-mx94-j49v

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources