Cleaning an ECS-enabled cache may cause excessive CPU load
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
If a resolver cache has a very large number of ECS records stored for the same name, the process of cleaning the cache database node for this name can significantly impair query performance. This issue affects BIND 9 versions 9.11.3-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.45-S1, and 9.18.11-S1 through 9.18.21-S1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ISC | BIND 9 | 9.11.3-S1 – 9.11.37-S1; 9.16.8-S1 – 9.16.45-S1; 9.18.11-S1 – 9.18.21-S1 | — | No fix listed | CNA |
- BIND 9 VendorISC Affected 9.11.3-S1 – 9.11.37-S1; 9.16.8-S1 – 9.16.45-S1; 9.18.11-S1 – 9.18.21-S1 Fixed in — No fix listed CNA
CPE configurations NVD · 28
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:9.11.3:s1:*:*:supported_preview:*:*:* | 9.11.3 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.3:s4:*:*:supported_preview:*:*:* | 9.11.3 s4 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.4:s1:*:*:supported_preview:*:*:* | 9.11.4 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.5:s3:*:*:supported_preview:*:*:* | 9.11.5 s3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.5:s5:*:*:supported_preview:*:*:* | 9.11.5 s5 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.5:s6:*:*:supported_preview:*:*:* | 9.11.5 s6 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.6:s1:*:*:supported_preview:*:*:* | 9.11.6 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.7:s1:*:*:supported_preview:*:*:* | 9.11.7 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.8:s1:*:*:supported_preview:*:*:* | 9.11.8 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.12:s1:*:*:supported_preview:*:*:* | 9.11.12 s1 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:9.11.3:s1:*:*:supported_preview:*:*:* Versions 9.11.3 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.3:s4:*:*:supported_preview:*:*:* Versions 9.11.3 s4 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.4:s1:*:*:supported_preview:*:*:* Versions 9.11.4 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.5:s3:*:*:supported_preview:*:*:* Versions 9.11.5 s3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.5:s5:*:*:supported_preview:*:*:* Versions 9.11.5 s5 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.5:s6:*:*:supported_preview:*:*:* Versions 9.11.5 s6 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.6:s1:*:*:supported_preview:*:*:* Versions 9.11.6 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.7:s1:*:*:supported_preview:*:*:* Versions 9.11.7 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.8:s1:*:*:supported_preview:*:*:* Versions 9.11.8 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.12:s1:*:*:supported_preview:*:*:* Versions 9.11.12 s1 Vulnerable ·ISC
Show 18 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:9.11.21:s1:*:*:supported_preview:*:*:* | 9.11.21 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.27:s1:*:*:supported_preview:*:*:* | 9.11.27 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.29:s1:*:*:supported_preview:*:*:* | 9.11.29 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.35:s1:*:*:supported_preview:*:*:* | 9.11.35 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.37:s1:*:*:supported_preview:*:*:* | 9.11.37 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.16.8:s1:*:*:supported_preview:*:*:* | 9.16.8 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.16.11:s1:*:*:supported_preview:*:*:* | 9.16.11 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.16.12:s1:*:*:supported_preview:*:*:* | 9.16.12 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.16.13:s1:*:*:supported_preview:*:*:* | 9.16.13 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.16.14:s1:*:*:supported_preview:*:*:* | 9.16.14 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.16.21:s1:*:*:supported_preview:*:*:* | 9.16.21 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.16.32:s1:*:*:supported_preview:*:*:* | 9.16.32 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.16.36:s1:*:*:supported_preview:*:*:* | 9.16.36 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.16.43:s1:*:*:supported_preview:*:*:* | 9.16.43 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.18.11:s1:*:*:supported_preview:*:*:* | 9.18.11 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.18.18:s1:*:*:supported_preview:*:*:* | 9.18.18 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.18.21:s1:*:*:supported_preview:*:*:* | 9.18.21 s1 | Vulnerable | ISC |
| cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:isc:bind:9.11.21:s1:*:*:supported_preview:*:*:* Versions 9.11.21 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.27:s1:*:*:supported_preview:*:*:* Versions 9.11.27 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.29:s1:*:*:supported_preview:*:*:* Versions 9.11.29 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.35:s1:*:*:supported_preview:*:*:* Versions 9.11.35 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.37:s1:*:*:supported_preview:*:*:* Versions 9.11.37 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.16.8:s1:*:*:supported_preview:*:*:* Versions 9.16.8 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.16.11:s1:*:*:supported_preview:*:*:* Versions 9.16.11 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.16.12:s1:*:*:supported_preview:*:*:* Versions 9.16.12 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.16.13:s1:*:*:supported_preview:*:*:* Versions 9.16.13 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.16.14:s1:*:*:supported_preview:*:*:* Versions 9.16.14 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.16.21:s1:*:*:supported_preview:*:*:* Versions 9.16.21 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.16.32:s1:*:*:supported_preview:*:*:* Versions 9.16.32 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.16.36:s1:*:*:supported_preview:*:*:* Versions 9.16.36 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.16.43:s1:*:*:supported_preview:*:*:* Versions 9.16.43 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.18.11:s1:*:*:supported_preview:*:*:* Versions 9.18.11 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.18.18:s1:*:*:supported_preview:*:*:* Versions 9.18.18 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.18.21:s1:*:*:supported_preview:*:*:* Versions 9.18.21 s1 Vulnerable ·ISC
- cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5680
- 2026-10-03 Alias added: GHSA-m868-f948-vvjc
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
More ISC Bind vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
- TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
Sources
- CVE-2023-5680 · CVE Program
- CVE-2023-5680 · NVD
- FIRST EPSS
- GHSA-m868-f948-vvjc · GitHub Advisory Database · CC BY 4.0
- CVE-2023-5680 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences