Read the docs
TI-2023-05291 Aliases CVE-2023-5752GHSA-mq26-g339-26xf

Mercurial configuration injectable in repo revision when installing via pip

Priority LOW 25CWE-77Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
None · High · None
Fix status
Partial Red Hat: 2 fixed, 4 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-77.

Summary

When installing a package from a Mercurial VCS URL (ie "pip install hg+...") with pip prior to v23.3, the specified Mercurial revision could be used to inject arbitrary configuration options to the "hg clone" call (ie "--config"). Controlling the Mercurial configuration can modify how and which repository is installed. This vulnerability does not affect users who aren't installing from Mercurial.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00502 43rd percentileScored 2026-11-07
Fix Partial pip (Pip maintainers): 23.3pip (PyPI): 23.3Red Hat: 1 advisoryRed Hat: 2 fixed, 4 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Pip maintainerspip—23.3Patch availableCNA
—pip (PyPI)before 23.323.3Patch availableGHSA-mq26-g339-26xf
  • pip VendorPip maintainers Affected — Fixed in 23.3 Patch available CNA
  • pip (PyPI) Vendor— Affected before 23.3 Fixed in 23.3 Patch available GHSA-mq26-g339-26xf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pypa:pip:*:*:*:*:*:*:*:*before 23.3Vulnerablepypa
  • cpe:2.3:a:pypa:pip:*:*:*:*:*:*:*:* Versions before 23.3 Vulnerable ·pypa

Remediation

  • Fix · CNA pip (Pip maintainers) Fixed in 23.3
  • Fix · GHSA-mq26-g339-26xf pip (PyPI) Fixed in 23.3 Advisory →

Red Hat 1 advisory

  • RHSA-2024:3781 Released 2024-06-10 · Red Hat rating Moderate
    Red Hat Ansible Automation Platform 2.4 Product Security and Bug Fix Update
    • Red Hat Ansible Automation Platform 2.4 for RHEL 8 automation-controller-venv-tower-4.5.7-1.el8ap, automation-hub-4.9.2-1.el8ap, python39-aiohttp-3.9.5-1.el8ap +25
    • Red Hat Ansible Automation Platform 2.4 for RHEL 9 automation-controller-venv-tower-4.5.7-1.el9ap, automation-hub-4.9.2-1.el9ap, python-aiohttp-3.9.5-1.el9ap +25

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 9AffectedNo fix yet: Fix deferred
Red Hat OpenShift Dev SpacesAffectedNo fix yet: Fix deferred
Red Hat Quay 3AffectedNo fix yet: Fix deferred
Red Hat Ansible Automation Platform 2.4 for RHEL 8Fixed RHSA-2024:3781
Red Hat Ansible Automation Platform 2.4 for RHEL 9Fixed RHSA-2024:3781
Not affected: 8 products
  • Red Hat Ansible Automation Platform 1.2
  • Red Hat Ansible Automation Platform 2
  • Red Hat Ansible Automation Platform 2.4 for RHEL 8
  • Red Hat Ansible Automation Platform 2.4 for RHEL 9
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Service Telemetry Framework 1.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5752
  2. 2026-10-03 Alias added: GHSA-mq26-g339-26xf

References

  • TI-2026-05576 pip self-update functionality can import newly installed modules after wheel installation CVSS 4.0MEDIUM 5.3

Sources