Amazonify <= 0.8.1 - Authenticated (Admin+) Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Amazonify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 0.8.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled. However, please note that this can also be combined with CVE-2023-5818 for CSRF to XSS.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| garykeorkunian | Amazonify | up to 0.8.1 | — | No fix listed | CNA |
- Amazonify Vendorgarykeorkunian Affected up to 0.8.1 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5819
- 2026-10-03 Alias added: GHSA-hc6p-9rvv-9qq4
References
More Gara Amazonify vulnerabilities
- TI-2023-05354 Amazonify <= 0.8.1 - Cross-Site Request Forgery to Amazon Tracking ID Update CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-5819 · CVE Program
- CVE-2023-5819 · NVD
- FIRST EPSS
- GHSA-hc6p-9rvv-9qq4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences