Read the docs
TI-2023-05474 Aliases CVE-2023-5942GHSA-5c7f-c4vf-5xcw

Medialist < 1.4.1 - Contributor+ Stored XSS

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Medialist WordPress plugin before 1.4.1 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00452 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Medialist (Unknown): 1.4.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownMedialistbefore 1.4.11.4.1Patch availableCNA
  • Medialist VendorUnknown Affected before 1.4.1 Fixed in 1.4.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drelton:medialist:*:*:*:*:*:wordpress:*:*before 1.4.1VulnerableD. Relton
  • cpe:2.3:a:drelton:medialist:*:*:*:*:*:wordpress:*:* Versions before 1.4.1 Vulnerable ·D. Relton

Remediation

  • Fix · CNA Medialist (Unknown) Fixed in 1.4.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5942
  2. 2026-10-03 Alias added: GHSA-5c7f-c4vf-5xcw

References

  • TI-2023-25142 WordPress Medialist Plugin <= 1.3.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources