Log injection in YugabyteDB
Priority LOW 35CWE-117Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
YugabyteDB is vulnerable to cross site scripting (XSS) via log injection. Writing invalidated user input to log files can allow an unprivileged attacker to forge log entries or inject malicious content into the logs.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00405 35th percentileScored 2026-11-07
Fix Fixed YugabyteDB (YugabyteDB): 2.14.14.0, 2.16.8.0, 2.18.4.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| YugabyteDB | YugabyteDB | 2.0.0.0 – 2.14.13.0, 2.16.7.0, 2.18.3.0 | 2.14.14.0, 2.16.8.0, 2.18.4.0 | Patch available | CNA |
- YugabyteDB VendorYugabyteDB Affected 2.0.0.0 – 2.14.13.0, 2.16.7.0, 2.18.3.0 Fixed in 2.14.14.0, 2.16.8.0, 2.18.4.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yugabyte:yugabytedb:*:*:*:*:*:*:*:* | 2.14.0.0 to before 2.14.14.0; 2.16.0.0 to before 2.16.8.0; 2.18.0.0 to before 2.18.4.0 | Vulnerable | YugabyteDB |
- cpe:2.3:a:yugabyte:yugabytedb:*:*:*:*:*:*:*:* Versions 2.14.0.0 to before 2.14.14.0; 2.16.0.0 to before 2.16.8.0; 2.18.0.0 to before 2.18.4.0 Vulnerable ·YugabyteDB
Remediation
- Fix · CNA YugabyteDB (YugabyteDB) Fixed in 2.14.14.0, 2.16.8.0, 2.18.4.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6002
- 2026-10-03 Alias added: GHSA-p56w-h56q-c97x
References
Other 1
More Yugabytedb vulnerabilities
- TI-2024-27623 YugabyteDB v2.21.1.0 was discovered to contain a buffer overflow via the "insert into" parameter. CVSS 3.1HIGH 7.5
- TI-2023-00545 Remote code execution in YugabyteDB CVSS 3.1CRITICAL 9.8
- TI-2022-17471 The software is vulnerable when using LDAP-based authentication in YCQL with Microsoft’s Active Directory CVSS 3.1CRITICAL 9.8
- TI-2023-05529 Prometheus Metrics Accessible Pre-Authentication CVSS 3.1HIGH 7.5
- TI-2023-04277 Set Logging Level Without Authentication CVSS 3.1HIGH 7.5
Sources
- CVE-2023-6002 · CVE Program
- CVE-2023-6002 · NVD
- FIRST EPSS
- GHSA-p56w-h56q-c97x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences