Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper neutralization of input in Jira integration configuration in GitLab CE/EE, affecting all versions from 15.10 prior to 16.6.1, 16.5 prior to 16.5.3, and 16.4 prior to 16.4.3 allows attacker to execute javascript in victim's browser.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 15.10 to before 16.4.3; 16.5 to before 16.5.3; 16.6 to before 16.6.1 | 16.4.3, 16.5.3, 16.6.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 15.10 to before 16.4.3; 16.5 to before 16.5.3; 16.6 to before 16.6.1 Fixed in 16.4.3, 16.5.3, 16.6.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.10 to before 16.6.1 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.10 to before 16.6.1 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.4.0 to before 16.4.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.4.0 to before 16.4.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.5.0 to before 16.5.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.5.0 to before 16.5.3 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.10 to before 16.6.1 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.10 to before 16.6.1 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.4.0 to before 16.4.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.4.0 to before 16.4.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.5.0 to before 16.5.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.5.0 to before 16.5.3 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 16.4.3, 16.5.3, 16.6.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 16.4.3, 16.5.3, 16.6.1
9 records Highest priority Priority MEDIUM 2 MEDIUM, 7 LOW
Other records, highest priority first
- TI-2023-03670 Insertion of Sensitive Information Into Sent Data in GitLabPriority MEDIUM 63
- TI-2023-03681 Incorrect Authorization in GitLabPriority MEDIUM 53
- TI-2023-05524 Incorrect Authorization in GitLabPriority LOW 34
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6033
- 2026-10-03 Alias added: GHSA-3xf7-rc79-2xq6
References
Exploit 1
Advisory 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-6033 · CVE Program
- CVE-2023-6033 · NVD
- FIRST EPSS
- GHSA-3xf7-rc79-2xq6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences