POLY1305 MAC implementation corrupts vector registers on PowerPC
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Partial Red Hat: 3 fixed, 6 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat.
Summary
Issue summary: The POLY1305 MAC (message authentication code) implementation contains a bug that might corrupt the internal state of applications running on PowerPC CPU based platforms if the CPU provides vector instructions. Impact summary: If an attacker can influence whether the POLY1305 MAC algorithm is used, the application state might be corrupted with various application dependent consequences. The POLY1305 MAC (message authentication code) implementation in OpenSSL for PowerPC CPUs restores the contents of vector registers in a different order than they are saved. Thus the contents of some of these vector registers are corrupted when returning to the caller. The vulnerable code is used only on newer PowerPC processors supporting the PowerISA 2.07 instructions. The consequences of this kind of internal application state corruption can be various - from no consequences, if the calling application does not depend on the contents of non-volatile XMM registers at all, to the worst consequences, where the attacker could get complete control of the application process. However unless the compiler uses the vector registers for storing pointers, the most likely consequence, if any, would be an incorrect result of some application dependent calculations or a crash leading to a denial of service. The POLY1305 MAC algorithm is most frequently used as part of the CHACHA20-POLY1305 AEAD (authenticated encryption with associated data) algorithm. The most common usage of this AEAD cipher is with TLS protocol versions 1.2 and 1.3. If this cipher is enabled on the server a malicious client can influence whether this AEAD cipher is used. This implies that TLS server applications using OpenSSL can be potentially impacted. However we are currently not aware of any concrete application that would be affected by this issue therefore we consider this a Low severity security issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenSSL | OpenSSL | 3.2.0 to before 3.2.1; 3.1.0 to before 3.1.5; 3.0.0 to before 3.0.13 | 3.2.1, 3.1.5, 3.0.13 | Patch available | CNA |
- OpenSSL VendorOpenSSL Affected 3.2.0 to before 3.2.1; 3.1.0 to before 3.1.5; 3.0.0 to before 3.0.13 Fixed in 3.2.1, 3.1.5, 3.0.13 Patch available CNA
Remediation
- Fix · CNA OpenSSL (OpenSSL) Fixed in 3.2.1, 3.1.5, 3.0.13
Red Hat 2 advisories
- RHSA-2024:9088 Released 2024-11-12 · Red Hat rating Moderateedk2 security update
- Red Hat CodeReady Linux Builder (v. 9) edk2-aarch64-20240524-6.el9_5, edk2-ovmf-20240524-6.el9_5, edk2-tools-20240524-6.el9_5 +1
- Red Hat Enterprise Linux AppStream (v. 9) edk2-20240524-6.el9_5, edk2-aarch64-20240524-6.el9_5, edk2-ovmf-20240524-6.el9_5
- RHSA-2024:2447 Released 2024-04-30 · Red Hat rating Lowopenssl and openssl-fips-provider security update
- Red Hat Enterprise Linux AppStream (v. 9) openssl-devel-1:3.0.7-27.el9, openssl-perl-1:3.0.7-27.el9
- Red Hat Enterprise Linux BaseOS (v. 9) openssl-1:3.0.7-27.el9, openssl-libs-1:3.0.7-27.el9
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Software Collections | Affected | No fix planned: Out of support scope |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2024:9088 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:2447, RHSA-2024:9088 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2024:2447 |
Not affected: 9 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Enterprise Linux BaseOS (v. 9)
- Red Hat JBoss Core Services
- Red Hat JBoss Web Server 5
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6129
- 2026-10-03 Alias added: GHSA-rj8q-prqp-jwfg
References
Advisory 1
More Openssl vulnerabilities
- TI-2022-01915 The c_rehash script allows command injection CVSS 3.1CRITICAL 9.8
- TI-2021-02645 SM2 Decryption Buffer Overflow CVSS 3.1CRITICAL 9.8
- TI-2009-03392 The TLS protocol, and the SSL protocol 3.0 and possibly earlier, as used in Microsoft… CVSS 3.1CRITICAL 9.8
- TI-2022-01176 The c_rehash script allows command injection CVSS 3.1CRITICAL 9.8
- TI-2014-00154 The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly… KEVCVSS 3.1HIGH 7.5
- TI-2025-14107 Stack buffer overflow in CMS (Auth)EnvelopedData parsing CVSS 3.1HIGH 8.8
Sources
- CVE-2023-6129 · CVE Program
- CVE-2023-6129 · NVD
- FIRST EPSS
- GHSA-rj8q-prqp-jwfg · GitHub Advisory Database · CC BY 4.0
- CVE-2023-6129 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences