Ecwid Ecommerce Shopping Cart < 6.12.5 - Arbitrary Plugin Settings Change via CSRF
Priority MEDIUM 53CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The Ecwid Ecommerce Shopping Cart WordPress plugin before 6.12.5 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00217 12th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Ecwid Ecommerce Shopping Cart (Unknown): 6.12.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ecwid Ecommerce Shopping Cart | before 6.12.5 | 6.12.5 | Patch available | CNA |
- Ecwid Ecommerce Shopping Cart VendorUnknown Affected before 6.12.5 Fixed in 6.12.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:lightspeedhq:ecwid_ecommerce_shopping_cart:*:*:*:*:*:wordpress:*:* | before 6.12.5 | Vulnerable | Ecwid Ecommerce |
- cpe:2.3:a:lightspeedhq:ecwid_ecommerce_shopping_cart:*:*:*:*:*:wordpress:*:* Versions before 6.12.5 Vulnerable ·Ecwid Ecommerce
Remediation
- Fix · CNA Ecwid Ecommerce Shopping Cart (Unknown) Fixed in 6.12.5
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6292
- 2026-10-03 Alias added: GHSA-wmg5-vm74-qqx4
References
More Ecwid Ecommerce Shopping Cart vulnerabilities
- TI-2022-02246 Ecwid Ecommerce Shopping Cart <= 6.10.23 - Cross-Site Request Forgery to Settings/Options Update CVSS 3.1HIGH 8.8
- TI-2023-09999 WordPress Ecwid Shopping Cart Plugin <= 6.11.3 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-10030 WordPress Ecwid Shopping Cart Plugin <= 6.11.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-28185 WordPress Ecwid Shopping Cart Plugin <= 6.12.4 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1MEDIUM 6.1
- TI-2024-12821 Ecwid by Lightspeed Ecommerce Shopping Cart <= 6.12.27 - Cross-Site Request Forgery to Send Deactivation Message CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-6292 · CVE Program
- CVE-2023-6292 · NVD
- FIRST EPSS
- GHSA-wmg5-vm74-qqx4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences