Allow SVG < 1.2.0 - Author+ Stored XSS via SVG
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Allow SVG WordPress plugin before 1.2.0 does not sanitize uploaded SVG files, which could allow users with a role as low as Author to upload a malicious SVG containing XSS payloads.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0039 33rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Allow SVG (Unknown): 1.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Allow SVG | before 1.2.0 | 1.2.0 | Patch available | CNA |
- Allow SVG VendorUnknown Affected before 1.2.0 Fixed in 1.2.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wphelpline:allow_svg:*:*:*:*:*:wordpress:*:* | before 1.2.0 | Vulnerable | Wphelpline |
- cpe:2.3:a:wphelpline:allow_svg:*:*:*:*:*:wordpress:*:* Versions before 1.2.0 Vulnerable ·Wphelpline
Remediation
- Fix · CNA Allow SVG (Unknown) Fixed in 1.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6541
- 2026-10-03 Alias added: GHSA-rf8c-553r-qgf7
References
Sources
- CVE-2023-6541 · CVE Program
- CVE-2023-6541 · NVD
- FIRST EPSS
- GHSA-rf8c-553r-qgf7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences