Improper Certificate Validation in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-295.
Summary
An improper certificate validation issue in Smartcard authentication in GitLab EE affecting all versions from 11.6 prior to 16.4.4, 16.5 prior to 16.5.4, and 16.6 prior to 16.6.2 allows an attacker to authenticate as another user given their public key if they use Smartcard authentication. Smartcard authentication is an experimental feature and has to be manually enabled by an administrator.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 11.6 to before 16.4.4; 16.5 to before 16.5.4; 16.6 to before 16.6.2 | 16.4.4, 16.5.4, 16.6.2 | Patch available | CNA |
- GitLab VendorGitLab Affected 11.6 to before 16.4.4; 16.5 to before 16.5.4; 16.6 to before 16.6.2 Fixed in 16.4.4, 16.5.4, 16.6.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 11.6 to before 16.4.4; 16.5 to before 16.5.4; 16.6 to before 16.6.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 11.6 to before 16.4.4; 16.5 to before 16.5.4; 16.6 to before 16.6.2 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 16.4.4, 16.5.4, 16.6.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 16.4.4, 16.5.4, 16.6.2
5 records Highest priority Priority MEDIUM 1 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2023-04661 Missing Authorization in GitLabPriority MEDIUM 53
- TI-2023-05572 Improper Control of Generation of Code ('Code Injection') in GitLabPriority LOW 30
- TI-2023-05073 Improper Control of Generation of Code ('Code Injection') in GitLabPriority LOW 26
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6680
- 2026-10-03 Alias added: GHSA-wpj8-2grx-f965
References
Other 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-6680 · CVE Program
- CVE-2023-6680 · NVD
- FIRST EPSS
- GHSA-wpj8-2grx-f965 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences