PAN-OS: DOM-Based Cross-Site Scripting (XSS) Vulnerability in the Web Interface
Priority LOW 39CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A DOM-Based cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS software enables a remote attacker to execute a JavaScript payload in the context of an administrator’s browser when they view a specifically crafted link to the PAN-OS web interface.
Why it matters now
EPSS 0.00659 51st percentileScored 2026-11-07
Fix Fixed PAN-OS (Palo Alto Networks): 8.1.25, 9.0.17, 9.1.16 +5Prisma Access (Palo Alto Networks): All+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | PAN-OS | 8.1 to before 8.1.25; 9.0 to before 9.0.17; 9.1 to before 9.1.16; 10.0 to before 10.0.12; 10.1 to before 10.1.9; 10.2 to before 10.2.4; 11.0 to before 11.0.1 | 8.1.25, 9.0.17, 9.1.16, 10.0.12, 10.1.9, 10.2.4, 11.0.1, 11.1 | Patch available | CNA |
| Palo Alto Networks | Prisma Access | — | All | Patch available | CNA |
| Palo Alto Networks | Cloud NGFW | — | All | Patch available | CNA |
- PAN-OS VendorPalo Alto Networks Affected 8.1 to before 8.1.25; 9.0 to before 9.0.17; 9.1 to before 9.1.16; 10.0 to before 10.0.12; 10.1 to before 10.1.9; 10.2 to before 10.2.4; 11.0 to before 11.0.1 Fixed in 8.1.25, 9.0.17, 9.1.16, 10.0.12, 10.1.9, 10.2.4, 11.0.1, 11.1 Patch available CNA
- Prisma Access VendorPalo Alto Networks Affected — Fixed in All Patch available CNA
- Cloud NGFW VendorPalo Alto Networks Affected — Fixed in All Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* | 8.1.0 to before 8.1.25; 9.0.0 to before 9.0.17; 9.1.0 to before 9.1.16; 10.0.0 to before 10.0.12; 10.1.0 to before 10.1.9; 10.2.0 to before 10.2.4 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
| cpe:2.3:o:paloaltonetworks:pan-os:11.0.0:*:*:*:*:*:*:* | 11.0.0 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
- cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* Versions 8.1.0 to before 8.1.25; 9.0.0 to before 9.0.17; 9.1.0 to before 9.1.16; 10.0.0 to before 10.0.12; 10.1.0 to before 10.1.9; 10.2.0 to before 10.2.4 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
- cpe:2.3:o:paloaltonetworks:pan-os:11.0.0:*:*:*:*:*:*:* Versions 11.0.0 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
Remediation
- Fix · CNA PAN-OS (Palo Alto Networks) Fixed in 8.1.25, 9.0.17, 9.1.16, 10.0.12, 10.1.9, 10.2.4, 11.0.1, 11.1
- Fix · CNA Prisma Access (Palo Alto Networks) Fixed in All
- Fix · CNA Cloud NGFW (Palo Alto Networks) Fixed in All
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6790
- 2026-10-03 Alias added: GHSA-8r5w-j8rm-886w
- 2026-10-09 EPSS moved to the 50th–90th percentile
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2023-6790 · CVE Program
- CVE-2023-6790 · NVD
- FIRST EPSS
- GHSA-8r5w-j8rm-886w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences