Cross-site scripting in WSO2 API Manager
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Reflected XSS vulnerability can be exploited by tampering a request parameter in Authentication Endpoint. This can be performed in both authenticated and unauthenticated requests.
Why it matters now
EPSS 0.00433 37th percentileScored 2026-11-07
Fix Fixed WSO2 API Manager (WSO2): 3.1.0.14, 3.2.0.10WSO2 Identity Server (WSO2): 5.10.0.5+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 API Manager | 3.1.0.0 to before 3.1.0.14; 3.2.0.0 to before 3.2.0.10 | 3.1.0.14, 3.2.0.10 | Patch available | CNA |
| WSO2 | WSO2 Identity Server | 5.10.0.0 to before 5.10.0.5 | 5.10.0.5 | Patch available | CNA |
| WSO2 | WSO2 IS as Key Manager | 5.10.0.0 to before 5.10.0.5 | 5.10.0.5 | Patch available | CNA |
- WSO2 API Manager VendorWSO2 Affected 3.1.0.0 to before 3.1.0.14; 3.2.0.0 to before 3.2.0.10 Fixed in 3.1.0.14, 3.2.0.10 Patch available CNA
- WSO2 Identity Server VendorWSO2 Affected 5.10.0.0 to before 5.10.0.5 Fixed in 5.10.0.5 Patch available CNA
- WSO2 IS as Key Manager VendorWSO2 Affected 5.10.0.0 to before 5.10.0.5 Fixed in 5.10.0.5 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wso2:api_manager:3.1.0:*:*:*:*:*:*:* | 3.1.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server_as_key_manager:5.10.0:*:*:*:*:*:*:* | 5.10.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:identity_server:5.10.0:*:*:*:*:*:*:* | 5.10.0 | Vulnerable | WSO2 |
- cpe:2.3:a:wso2:api_manager:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server_as_key_manager:5.10.0:*:*:*:*:*:*:* Versions 5.10.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:identity_server:5.10.0:*:*:*:*:*:*:* Versions 5.10.0 Vulnerable ·WSO2
Remediation
- Fix · CNA WSO2 API Manager (WSO2) Fixed in 3.1.0.14, 3.2.0.10
- Fix · CNA WSO2 Identity Server (WSO2) Fixed in 5.10.0.5
- Fix · CNA WSO2 IS as Key Manager (WSO2) Fixed in 5.10.0.5
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6838
- 2026-10-03 Alias added: GHSA-355p-h43c-hhm8
References
More WSO2 Api Manager vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2022-11928 Certain WSO2 products allow unrestricted file upload with resultant remote code execution. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-15069 The Management Console in WSO2 API Manager through 3.1.0 and API Microgateway 2.2.0… CVSS 3.1CRITICAL 9.1
- TI-2023-15163 A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do… CVSS 3.1MEDIUM 6.1
- TI-2022-12002 A reflected XSS issue exists in the Management Console of several WSO2 products. CVSS 3.1MEDIUM 6.1
- TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
Sources
- CVE-2023-6838 · CVE Program
- CVE-2023-6838 · NVD
- FIRST EPSS
- GHSA-355p-h43c-hhm8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences