Read the docs
TI-2023-06257 Aliases CVE-2023-6852GHSA-v73r-f3cx-pm99

kalcaddle KodExplorer app.php server-side request forgery

Priority MEDIUM 43CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

A vulnerability classified as critical has been found in kalcaddle KodExplorer up to 4.51.03. Affected is an unknown function of the file plugins/webodf/app.php. The manipulation leads to server-side request forgery. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.52.01 is able to address this issue. The name of the patch is 5cf233f7556b442100cf67b5e92d57ceabb126c6. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-248220.

Why it matters now

EPSS 0.00762 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
kalcaddleKodExplorer4.51.03—No fix listedCNA
  • KodExplorer Vendorkalcaddle Affected 4.51.03 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:kodcloud:kodexplorer:*:*:*:*:*:*:*:*before 4.52.01Vulnerablekalcaddle
  • cpe:2.3:a:kodcloud:kodexplorer:*:*:*:*:*:*:*:* Versions before 4.52.01 Vulnerable ·kalcaddle

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-6852
  2. 2026-10-03 Alias added: GHSA-v73r-f3cx-pm99

References

  • TI-2023-06258 kalcaddle KodExplorer app.php index server-side request forgery CVSS 3.1CRITICAL 9.8
  • TI-2023-27035 Reflective Cross Site Scripting (XSS) vulnerability in KodExplorer version 4.51, allows… CVSS 3.1MEDIUM 6.1
  • TI-2023-18809 KodExplorer 4.51 contains a Cross-Site Scripting (XSS) vulnerability in the Description… CVSS 3.1MEDIUM 6.1
  • TI-2021-14827 A Cross Site Scrtpting (XSS) vulnerability in KodExplorer 4.45 allows remote attackers to… CVSS 3.1MEDIUM 6.1
  • TI-2025-24530 KodExplorer 4.52 Open Redirect Vulnerability via User Login Endpoint CVSS 4.0MEDIUM 5.3
  • TI-2022-22798 Arbitrary file access in KodExplorer CVSS 3.1HIGH 8.6
See all 9 →

Sources