Limit Login Attempts Reloaded <= 2.25.26 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Limit Login Attempts Reloaded plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including, 2.25.26 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wpchefgadget | Limit Login Attempts Reloaded – Login Security, 2FA, Brute Force Protection & Firewall | up to 2.25.26 | — | No fix listed | CNA |
- Limit Login Attempts Reloaded – Login Security, 2FA, Brute Force Protection & Firewall Vendorwpchefgadget Affected up to 2.25.26 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:limitloginattempts:limit_login_attempts_reloaded:*:*:*:*:*:wordpress:*:* | up to 2.25.26 | Vulnerable | Limitloginattempts |
- cpe:2.3:a:limitloginattempts:limit_login_attempts_reloaded:*:*:*:*:*:wordpress:*:* Versions up to 2.25.26 Vulnerable ·Limitloginattempts
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6934
- 2026-10-03 Alias added: GHSA-gpw4-j4h5-577f
References
More Limitloginattempts Limit Login Attempts Reloaded vulnerabilities
- TI-2023-05084 Limit Login Attempts Reloaded < 2.25.26 - Admin+ Missing Authorization to Toggle Plugin Auto-Update CVSS 3.1MEDIUM 4.3
- TI-2020-18094 LimitLoginAttempts.php in the limit-login-attempts-reloaded plugin before 2.17.4 for… CVSS 3.1CRITICAL 9.8
- TI-2020-18093 The limit-login-attempts-reloaded plugin before 2.17.4 for WordPress allows… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-6934 · CVE Program
- CVE-2023-6934 · NVD
- FIRST EPSS
- GHSA-gpw4-j4h5-577f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences