KylinSoft kylin-system-updater com.kylin.systemupgrade Service UpgradeStrategiesDbus.py os command injection
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
A vulnerability classified as critical has been found in KylinSoft kylin-system-updater up to 2.0.5.16-0k2.33. Affected is an unknown function of the file /usr/share/kylin-system-updater/SystemUpdater/UpgradeStrategiesDbus.py of the component com.kylin.systemupgrade Service. The manipulation of the argument SetDownloadspeedMax leads to os command injection. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. The identifier of this vulnerability is VDB-248940. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| KylinSoft | kylin-system-updater | 2.0.5.16-0k2.0; 2.0.5.16-0k2.1; 2.0.5.16-0k2.2; 2.0.5.16-0k2.3; 2.0.5.16-0k2.4; 2.0.5.16-0k2.5; 2.0.5.16-0k2.6; 2.0.5.16-0k2.7; 2.0.5.16-0k2.8; 2.0.5.16-0k2.9; 2.0.5.16-0k2.10; 2.0.5.16-0k2.11; 2.0.5.16-0k2.12; 2.0.5.16-0k2.13; 2.0.5.16-0k2.14; 2.0.5.16-0k2.15; 2.0.5.16-0k2.16; 2.0.5.16-0k2.17; 2.0.5.16-0k2.18; 2.0.5.16-0k2.19; 2.0.5.16-0k2.20; 2.0.5.16-0k2.21; 2.0.5.16-0k2.22; 2.0.5.16-0k2.23; 2.0.5.16-0k2.24; 2.0.5.16-0k2.25; 2.0.5.16-0k2.26; 2.0.5.16-0k2.27; 2.0.5.16-0k2.28; 2.0.5.16-0k2.29; 2.0.5.16-0k2.30; 2.0.5.16-0k2.31; 2.0.5.16-0k2.32; 2.0.5.16-0k2.33 | — | No fix listed | CNA |
- kylin-system-updater VendorKylinSoft Affected 2.0.5.16-0k2.0; 2.0.5.16-0k2.1; 2.0.5.16-0k2.2; 2.0.5.16-0k2.3; 2.0.5.16-0k2.4; 2.0.5.16-0k2.5; 2.0.5.16-0k2.6; 2.0.5.16-0k2.7; 2.0.5.16-0k2.8; 2.0.5.16-0k2.9; 2.0.5.16-0k2.10; 2.0.5.16-0k2.11; 2.0.5.16-0k2.12; 2.0.5.16-0k2.13; 2.0.5.16-0k2.14; 2.0.5.16-0k2.15; 2.0.5.16-0k2.16; 2.0.5.16-0k2.17; 2.0.5.16-0k2.18; 2.0.5.16-0k2.19; 2.0.5.16-0k2.20; 2.0.5.16-0k2.21; 2.0.5.16-0k2.22; 2.0.5.16-0k2.23; 2.0.5.16-0k2.24; 2.0.5.16-0k2.25; 2.0.5.16-0k2.26; 2.0.5.16-0k2.27; 2.0.5.16-0k2.28; 2.0.5.16-0k2.29; 2.0.5.16-0k2.30; 2.0.5.16-0k2.31; 2.0.5.16-0k2.32; 2.0.5.16-0k2.33 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-7093
- 2026-10-03 Alias added: GHSA-q6g2-4gw5-gw53
References
Sources
- CVE-2023-7093 · CVE Program
- CVE-2023-7093 · NVD
- FIRST EPSS
- GHSA-q6g2-4gw5-gw53 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences