Nagios XI < 2024R1.0.2 XSS via Core Command Expansion
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Nagios XI versions prior to < 2024R1.0.2 are vulnerable to cross-site scripting (XSS) via the Nagios Core Command Expansion page. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00587 48th percentileScored 2026-11-07
Fix Fixed XI (Nagios): 2024R1.0.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Nagios | XI | before 2024R1.0.2 | 2024R1.0.2 | Patch available | CNA |
- XI VendorNagios Affected before 2024R1.0.2 Fixed in 2024R1.0.2 Patch available CNA
Remediation
- Fix · CNA XI (Nagios) Fixed in 2024R1.0.2
Timeline
- 2026-10-02 Threatist record created from CVE-2023-7318
- 2026-10-03 Alias added: GHSA-vmqh-gxh7-q26x
References
More Nagios Xi vulnerabilities
- TI-2021-07545 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2021-07544 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2021-07543 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2019-11993 Nagios XI before 5.6.6 allows remote command execution as root. KEVCVSS 3.1HIGH 8.8
- TI-2023-26027 Nagios XI before version 5.11.3 was discovered to contain a remote code execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2018-11196 Snoopy 1.0 in Nagios XI 5.5.6 allows remote unauthenticated attackers to execute… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2023-7318 · CVE Program
- CVE-2023-7318 · NVD
- FIRST EPSS
- GHSA-vmqh-gxh7-q26x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences