Belden Industrial HiVision Arbitrary Code Execution via Malicious Project File
Priority LOW 38CWE-269Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
Hirschmann Industrial HiVision versions 05.0.00 through 08.3.01 prior to 08.3.02 contain an arbitrary code execution vulnerability triggered when an administrator opens a maliciously crafted project file. Successful exploitation allows the attacker to execute code in the context of the HiVision process.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00144 3rd percentileScored 2026-11-07
Fix Fixed Hirschmann Industrial HiVision (Belden): 08.3.02
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Hirschmann Industrial HiVision (Belden) Fixed in 08.3.02
Timeline
- 2026-10-02 Threatist record created from CVE-2023-7343
- 2026-10-03 Alias added: GHSA-qq9p-jh9v-jwwc
References
Advisory 1
More Belden vulnerabilities
- TI-2019-09143 Wind River VxWorks has a Buffer Overflow in the TCP component (issue 1 of 4). CVSS 3.1CRITICAL 9.8
- TI-2019-09145 Wind River VxWorks 6.6 through 6.9 has a Buffer Overflow in the DHCP client component. CVSS 3.1HIGH 8.8
- TI-2022-19123 The web server of Hirschmann BAT-C2 before 09.13.01.00R04 allows authenticated command… CVSS 3.1HIGH 8.8
- TI-2019-09144 Wind River VxWorks 6.9 and vx7 has a Buffer Overflow in the IPv4 component. CVSS 3.1CRITICAL 9.8
- TI-2019-09148 Wind River VxWorks 6.9 and vx7 has a Buffer Overflow in the TCP component (issue 2 of 4). CVSS 3.1CRITICAL 9.8
- TI-2025-43113 A stored cross-site scripting (XSS) vulnerability exists in the web management interface… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-7343 · CVE Program
- CVE-2023-7343 · NVD
- FIRST EPSS
- GHSA-qq9p-jh9v-jwwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences