In Spring Security, versions 5.7.x prior to 5.7.8, versions 5.8.x prior to 5.8.3, and…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Partial Red Hat: 1 fixed, 11 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.
Summary
In Spring Security, versions 5.7.x prior to 5.7.8, versions 5.8.x prior to 5.8.3, and versions 6.0.x prior to 6.0.3, the logout support does not properly clean the security context if using serialized versions. Additionally, it is not possible to explicitly save an empty security context to the HttpSessionSecurityContextRepository. This vulnerability can keep users authenticated even after they performed logout. Users of affected versions should apply the following mitigation. 5.7.x users should upgrade to 5.7.8. 5.8.x users should upgrade to 5.8.3. 6.0.x users should upgrade to 6.0.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Spring Security | Spring Security, versions 5.7.x prior to 5.7.8, versions 5.8.x prior to 5.8.3, and versions 6.0.x prior to 6.0.3 | — | No fix listed | CNA |
| — | org.springframework.security:spring-security-core (Maven) | 5.7.0 to before 5.7.8 | 5.7.8 | Patch available | GHSA-x873-6rgc-94jc |
| — | org.springframework.security:spring-security-core (Maven) | 5.8.0 to before 5.8.3 | 5.8.3 | Patch available | GHSA-x873-6rgc-94jc |
| — | org.springframework.security:spring-security-core (Maven) | 6.0.0 to before 6.0.3 | 6.0.3 | Patch available | GHSA-x873-6rgc-94jc |
- Spring Security Vendor— Affected Spring Security, versions 5.7.x prior to 5.7.8, versions 5.8.x prior to 5.8.3, and versions 6.0.x prior to 6.0.3 Fixed in — No fix listed CNA
- org.springframework.security:spring-security-core (Maven) Vendor— Affected 5.7.0 to before 5.7.8 Fixed in 5.7.8 Patch available GHSA-x873-6rgc-94jc
- org.springframework.security:spring-security-core (Maven) Vendor— Affected 5.8.0 to before 5.8.3 Fixed in 5.8.3 Patch available GHSA-x873-6rgc-94jc
- org.springframework.security:spring-security-core (Maven) Vendor— Affected 6.0.0 to before 6.0.3 Fixed in 6.0.3 Patch available GHSA-x873-6rgc-94jc
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:* | 5.7.0 to before 5.7.8; 5.8.0 to before 5.8.3; 6.0.0 to before 6.0.3 | Vulnerable | VMware |
| cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:linux:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:windows:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:* Versions 5.7.0 to before 5.7.8; 5.8.0 to before 5.8.3; 6.0.0 to before 6.0.3 Vulnerable ·VMware
- cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:linux:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:windows:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
- Fix · GHSA-x873-6rgc-94jc org.springframework.security:spring-security-core (Maven) Fixed in 5.7.8 Advisory →
- Fix · GHSA-x873-6rgc-94jc org.springframework.security:spring-security-core (Maven) Fixed in 5.8.3 Advisory →
- Fix · GHSA-x873-6rgc-94jc org.springframework.security:spring-security-core (Maven) Fixed in 6.0.3 Advisory →
Red Hat 1 advisory
- RHSA-2024:0778 Released 2024-02-12 · Red Hat rating ImportantJenkins and Jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.12 jenkins-2-plugins-4.12.1706515741-1.el8, jenkins-2.426.3.1706515686-3.el8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Decision Manager 7 | Affected | No fix planned: Out of support scope |
| Red Hat Fuse 7 | Affected | No fix planned: Out of support scope |
| Red Hat Integration Camel Quarkus 2 | Affected | No fix planned: Will not fix |
| Red Hat JBoss A-MQ 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Enterprise Application Platform 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Fuse 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Fuse Service Works 6 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Dev Spaces | Affected | No fix yet |
| Red Hat Process Automation 7 | Affected | No fix planned: Out of support scope |
| Red Hat build of Quarkus | Affected | No fix planned: Will not fix |
| OpenShift Developer Tools and Services for OCP 4.12 | Fixed | RHSA-2024:0778 |
Not affected: 12 products
- A-MQ Clients 2
- OpenShift Developer Tools and Services for OCP 4.12
- Red Hat Data Grid 8
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat JBoss Data Grid 7
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Enterprise Application Platform 8
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- Red Hat OpenShift Container Platform 4
- Red Hat Single Sign-On 7
- Red Hat build of Apache Camel for Spring Boot 3
Timeline
- 2026-10-02 Threatist record created from CVE-2023-20862
- 2026-10-03 Alias added: GHSA-x873-6rgc-94jc
- 2026-10-18 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2023-20862 · CVE Program
- CVE-2023-20862 · NVD
- FIRST EPSS
- GHSA-x873-6rgc-94jc · GitHub Advisory Database · CC BY 4.0
- CVE-2023-20862 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences