Improper input validation in Samsung Galaxy Store
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
InstantPlay which included vulnerable script which could execute javascript in Galaxy Store prior to version 4.5.49.8 allows attackers to execute javascript API to install APK from Galaxy Store.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Galaxy Store (Samsung Mobile) Fixed in 4.5.49.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Samsung Mobile Galaxy Store 4.5.49.8
3 records Highest priority Priority MEDIUM 3 MEDIUM
Other records, highest priority first
- TI-2023-07917 Improper input validation in Samsung Galaxy StorePriority MEDIUM 48
- TI-2023-07915 Improper input validation in Samsung Galaxy StorePriority MEDIUM 41
Timeline
- 2026-10-02 Threatist record created from CVE-2023-21515
- 2026-10-03 Alias added: GHSA-6q4x-p962-hh53
References
More Samsung Galaxy Store vulnerabilities
- TI-2023-07917 Improper input validation in Samsung Galaxy Store CVSS 3.1CRITICAL 9.6
- TI-2023-22730 Improper URL validation from MCSLaunch deeplink in Galaxy Store prior to version 4.5.64.4… CVSS 3.1CRITICAL 9.8
- TI-2023-07835 Improper input validation in Samsung Galaxy Store CVSS 3.1MEDIUM 6.2
- TI-2023-07834 Improper authorization in Samsung Galaxy Store CVSS 3.1HIGH 7.8
- TI-2023-07915 Improper input validation in Samsung Galaxy Store CVSS 3.1HIGH 8.8
- TI-2023-22731 Improper URL validation from InstantPlay deeplink in Galaxy Store prior to version… CVSS 3.1HIGH 7.5
Sources
- CVE-2023-21515 · CVE Program
- CVE-2023-21515 · NVD
- FIRST EPSS
- GHSA-6q4x-p962-hh53 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences