Discourse vulnerable to Cross-site Scripting in local oneboxes
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Discourse is an open source platform for community discussion. Versions prior to 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed), are vulnerable to cross-site Scripting. A maliciously crafted URL can be included in a post to carry out cross-site scripting attacks on sites with disabled or overly permissive CSP (Content Security Policy). Discourse's default CSP prevents this vulnerability. This vulnerability is patched in versions 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed). As a workaround, enable and/or restore your site's CSP to the default one provided with Discourse.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | discourse | stable < 2.8.14; beta < 3.0.0.beta16; tests-passed < 3.0.0.beta16 | — | No fix listed | CNA |
- discourse Vendordiscourse Affected stable < 2.8.14; beta < 3.0.0.beta16; tests-passed < 3.0.0.beta16 Fixed in — No fix listed CNA
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:* | before 2.8.13 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta1:*:*:beta:*:*:* | 2.9.0 beta1 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta10:*:*:beta:*:*:* | 2.9.0 beta10 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta11:*:*:beta:*:*:* | 2.9.0 beta11 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta12:*:*:beta:*:*:* | 2.9.0 beta12 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta13:*:*:beta:*:*:* | 2.9.0 beta13 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta14:*:*:beta:*:*:* | 2.9.0 beta14 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta2:*:*:beta:*:*:* | 2.9.0 beta2 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta3:*:*:beta:*:*:* | 2.9.0 beta3 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta4:*:*:beta:*:*:* | 2.9.0 beta4 | Vulnerable | discourse |
- cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:* Versions before 2.8.13 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta1:*:*:beta:*:*:* Versions 2.9.0 beta1 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta10:*:*:beta:*:*:* Versions 2.9.0 beta10 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta11:*:*:beta:*:*:* Versions 2.9.0 beta11 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta12:*:*:beta:*:*:* Versions 2.9.0 beta12 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta13:*:*:beta:*:*:* Versions 2.9.0 beta13 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta14:*:*:beta:*:*:* Versions 2.9.0 beta14 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta2:*:*:beta:*:*:* Versions 2.9.0 beta2 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta3:*:*:beta:*:*:* Versions 2.9.0 beta3 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta4:*:*:beta:*:*:* Versions 2.9.0 beta4 Vulnerable ·discourse
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:discourse:discourse:2.9.0:beta5:*:*:beta:*:*:* | 2.9.0 beta5 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta6:*:*:beta:*:*:* | 2.9.0 beta6 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta7:*:*:beta:*:*:* | 2.9.0 beta7 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta8:*:*:beta:*:*:* | 2.9.0 beta8 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta9:*:*:beta:*:*:* | 2.9.0 beta9 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:3.0.0:beta15:*:*:beta:*:*:* | 3.0.0 beta15 | Vulnerable | discourse |
- cpe:2.3:a:discourse:discourse:2.9.0:beta5:*:*:beta:*:*:* Versions 2.9.0 beta5 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta6:*:*:beta:*:*:* Versions 2.9.0 beta6 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta7:*:*:beta:*:*:* Versions 2.9.0 beta7 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta8:*:*:beta:*:*:* Versions 2.9.0 beta8 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta9:*:*:beta:*:*:* Versions 2.9.0 beta9 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:3.0.0:beta15:*:*:beta:*:*:* Versions 3.0.0 beta15 Vulnerable ·discourse
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22468
References
More Discourse vulnerabilities
- TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
- TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
- TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
- TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
- TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
- TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences