Mercurius is vulnerable to denial of service (DoS) when using subscriptions
Priority HIGH 72CWE-248Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-248.
Summary
Mercurius is a GraphQL adapter for Fastify. Any users of Mercurius until version 10.5.0 are subjected to a denial of service attack by sending a malformed packet over WebSocket to `/graphql`. This issue was patched in #940. As a workaround, users can disable subscriptions.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01086 65th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mercurius (mercurius-js): 10.5.0mercurius (npm): 11.5.0, 8.13.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| mercurius-js | mercurius | before 10.5.0 | 10.5.0 | Patch available | CNA |
| — | mercurius (npm) | 9.0.0 to before 11.5.0 | 11.5.0 | Patch available | GHSA-cm8h-q92v-xcfc |
| — | mercurius (npm) | before 8.13.2 | 8.13.2 | Patch available | GHSA-cm8h-q92v-xcfc |
- mercurius Vendormercurius-js Affected before 10.5.0 Fixed in 10.5.0 Patch available CNA
- mercurius (npm) Vendor— Affected 9.0.0 to before 11.5.0 Fixed in 11.5.0 Patch available GHSA-cm8h-q92v-xcfc
- mercurius (npm) Vendor— Affected before 8.13.2 Fixed in 8.13.2 Patch available GHSA-cm8h-q92v-xcfc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mercurius_project:mercurius:*:*:*:*:*:node.js:*:* | before 8.13.2; 9.0.0 to before 11.5.0 | Vulnerable | mercurius-js |
- cpe:2.3:a:mercurius_project:mercurius:*:*:*:*:*:node.js:*:* Versions before 8.13.2; 9.0.0 to before 11.5.0 Vulnerable ·mercurius-js
Remediation
- Fix · CNA mercurius (mercurius-js) Fixed in 10.5.0
- Fix · GHSA-cm8h-q92v-xcfc mercurius (npm) Fixed in 11.5.0 Advisory →
- Fix · GHSA-cm8h-q92v-xcfc mercurius (npm) Fixed in 8.13.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22477
- 2026-10-03 Alias added: GHSA-cm8h-q92v-xcfc
References
Patch 2
More mercurius-js Mercurius vulnerabilities
- TI-2025-39610 Mercurius: Incorrect Content-Type parsing can lead to CSRF attack CVSS 3.1MEDIUM 5.4
- TI-2021-19607 Uncaught Exception in mercurius CVSS 3.1HIGH 7.5
- TI-2026-23474 Mercurius: queryDepth limit bypassed for WebSocket subscriptions CVSS 4.0LOW 2.7
Sources
- CVE-2023-22477 · CVE Program
- CVE-2023-22477 · NVD
- FIRST EPSS
- GHSA-cm8h-q92v-xcfc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences