Read the docs
TI-2023-08727 Aliases CVE-2023-22478GHSA-gqx8-hxmv-c4v4

KubePi is vulnerable to missing authorization

Priority MEDIUM 45CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

KubePi is a modern Kubernetes panel. The API interfaces with unauthorized entities and may leak sensitive information. This issue has been patched in version 1.6.4. There are currently no known workarounds.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.03737 89th percentileScored 2026-11-07
Fix Fixed github.com/KubeOperator/kubepi (Go): 1.6.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
1Panel-devKubePiup to 1.6.3—No fix listedCNA
—github.com/KubeOperator/kubepi (Go)before 1.6.41.6.4Patch availableGHSA-gqx8-hxmv-c4v4
  • KubePi Vendor1Panel-dev Affected up to 1.6.3 Fixed in — No fix listed CNA
  • github.com/KubeOperator/kubepi (Go) Vendor— Affected before 1.6.4 Fixed in 1.6.4 Patch available GHSA-gqx8-hxmv-c4v4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:fit2cloud:kubepi:*:*:*:*:*:*:*:*before 1.6.4Vulnerable1Panel-dev
  • cpe:2.3:a:fit2cloud:kubepi:*:*:*:*:*:*:*:* Versions before 1.6.4 Vulnerable ·1Panel-dev

Remediation

  • Fix · GHSA-gqx8-hxmv-c4v4 github.com/KubeOperator/kubepi (Go) Fixed in 1.6.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-22478
  2. 2026-10-03 Alias added: GHSA-gqx8-hxmv-c4v4

References

  • TI-2023-08712 KubePi's Hardcoded Jwtsigkeys allows malicious actor to login with a forged JWT token CVSS 3.1CRITICAL 9.8
  • TI-2023-19350 Privilege Escalation in kubepi CVSS 3.1CRITICAL 9.1
  • TI-2023-19349 Leak password hash of any user CVSS 3.1HIGH 7.5
  • TI-2023-08728 KubePi vulnerable to session fixation attack CVSS 3.1HIGH 7.5

Sources