KubeOperator is vulnerable to unauthorized access to system API
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
KubeOperator is an open source Kubernetes distribution focused on helping enterprises plan, deploy and operate production-level K8s clusters. In KubeOperator versions 3.16.3 and below, API interfaces with unauthorized entities and can leak sensitive information. This vulnerability could be used to take over the cluster under certain conditions. This issue has been patched in version 3.16.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| 1Panel-dev | KubeOperator | up to 3.16.3 | — | No fix listed | CNA |
| — | github.com/KubeOperator/KubeOperator (Go) | up to 3.16.3 | — | No fix listed | GHSA-jxgp-jgh3-8jc8 |
- KubeOperator Vendor1Panel-dev Affected up to 3.16.3 Fixed in — No fix listed CNA
- github.com/KubeOperator/KubeOperator (Go) Vendor— Affected up to 3.16.3 Fixed in — No fix listed GHSA-jxgp-jgh3-8jc8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fit2cloud:kubeoperator:*:*:*:*:*:*:*:* | before 3.16.4 | Vulnerable | 1Panel-dev |
- cpe:2.3:a:fit2cloud:kubeoperator:*:*:*:*:*:*:*:* Versions before 3.16.4 Vulnerable ·1Panel-dev
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22480
- 2026-10-03 Alias added: GHSA-jxgp-jgh3-8jc8
References
Patch 2
Advisory 2
Sources
- CVE-2023-22480 · CVE Program
- CVE-2023-22480 · NVD
- FIRST EPSS
- GHSA-jxgp-jgh3-8jc8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences