libzypp-plugin-appdata: potential arbitrary code execution via shell injection due to `os.system` calls
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
An Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in libzypp-plugin-appdata of SUSE Linux Enterprise Server for SAP 15-SP3; openSUSE Leap 15.4 allows attackers that can trick users to use specially crafted REPO_ALIAS, REPO_TYPE or REPO_METADATA_PATH settings to execute code as root. This issue affects: SUSE Linux Enterprise Server for SAP 15-SP3 libzypp-plugin-appdata versions prior to 1.0.1+git.20180426. openSUSE Leap 15.4 libzypp-plugin-appdata versions prior to 1.0.1+git.20180426.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise Server for SAP 15-SP3 | libzypp-plugin-appdata to before 1.0.1+git.20180426 | 1.0.1+git.20180426 | Patch available | CNA |
| openSUSE | openSUSE Leap 15.4 | libzypp-plugin-appdata to before 1.0.1+git.20180426 | 1.0.1+git.20180426 | Patch available | CNA |
- SUSE Linux Enterprise Server for SAP 15-SP3 VendorSUSE Affected libzypp-plugin-appdata to before 1.0.1+git.20180426 Fixed in 1.0.1+git.20180426 Patch available CNA
- openSUSE Leap 15.4 VendoropenSUSE Affected libzypp-plugin-appdata to before 1.0.1+git.20180426 Fixed in 1.0.1+git.20180426 Patch available CNA
Remediation
- Fix · CNA SUSE Linux Enterprise Server for SAP 15-SP3 (SUSE) Fixed in 1.0.1+git.20180426
- Fix · CNA openSUSE Leap 15.4 (openSUSE) Fixed in 1.0.1+git.20180426
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22643
- 2026-10-03 Alias added: GHSA-7mcm-wrpj-6fwv
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-22643 · CVE Program
- CVE-2023-22643 · NVD
- FIRST EPSS
- GHSA-7mcm-wrpj-6fwv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences