Rancher 'Audit Log' leaks sensitive information
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-532.
Summary
A vulnerability has been identified which may lead to sensitive data being leaked into Rancher's audit logs. [Rancher Audit Logging](https://ranchermanager.docs.rancher.com/how-to-guides/advanced-user-guides/enable-api-audit-log) is an opt-in feature, only deployments that have it enabled and have [AUDIT_LEVEL](https://ranchermanager.docs.rancher.com/how-to-guides/advanced-user-guides/enable-api-audit-log#audit-log-levels) set to `1 or above` are impacted by this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | rancher | 2.6.0 to before 2.6.14; 2.7.0 to before 2.7.10; 2.8.0 to before 2.8.2 | 2.6.14, 2.7.10, 2.8.2 | Patch available | CNA |
| — | github.com/rancher/rancher (Go) | 2.6.0 to before 2.6.14 | 2.6.14 | Patch available | GHSA-xfj7-qf8w-2gcr |
| — | github.com/rancher/rancher (Go) | 2.7.0 to before 2.7.10 | 2.7.10 | Patch available | GHSA-xfj7-qf8w-2gcr |
| — | github.com/rancher/rancher (Go) | 2.8.0 to before 2.8.2 | 2.8.2 | Patch available | GHSA-xfj7-qf8w-2gcr |
- rancher VendorSUSE Affected 2.6.0 to before 2.6.14; 2.7.0 to before 2.7.10; 2.8.0 to before 2.8.2 Fixed in 2.6.14, 2.7.10, 2.8.2 Patch available CNA
- github.com/rancher/rancher (Go) Vendor— Affected 2.6.0 to before 2.6.14 Fixed in 2.6.14 Patch available GHSA-xfj7-qf8w-2gcr
- github.com/rancher/rancher (Go) Vendor— Affected 2.7.0 to before 2.7.10 Fixed in 2.7.10 Patch available GHSA-xfj7-qf8w-2gcr
- github.com/rancher/rancher (Go) Vendor— Affected 2.8.0 to before 2.8.2 Fixed in 2.8.2 Patch available GHSA-xfj7-qf8w-2gcr
Remediation
- Fix · CNA rancher (SUSE) Fixed in 2.6.14, 2.7.10, 2.8.2
- Fix · GHSA-xfj7-qf8w-2gcr github.com/rancher/rancher (Go) Fixed in 2.6.14 Advisory →
- Fix · GHSA-xfj7-qf8w-2gcr github.com/rancher/rancher (Go) Fixed in 2.7.10 Advisory →
- Fix · GHSA-xfj7-qf8w-2gcr github.com/rancher/rancher (Go) Fixed in 2.8.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
SUSE rancher 2.6.14, 2.7.10, 2.8.2
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2023-15495 Rancher permissions on 'namespaces' in any API group grants 'edit' permissions on namespaces in 'core'Priority MEDIUM 40
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22649
- 2026-10-03 Alias added: GHSA-xfj7-qf8w-2gcr
References
More SUSE Rancher vulnerabilities
- TI-2021-14903 Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object CVSS 3.1CRITICAL 9.9
- TI-2022-21489 Rancher: Non-random authentication token CVSS 3.1CRITICAL 9.8
- TI-2019-08380 An issue was discovered that affects the following versions of Rancher: v2.0.0 through… CVSS 3.0CRITICAL 9.8
- TI-2023-08827 Improper privilege management in SUSE Rancher CVSS 3.1CRITICAL 9.9
- TI-2023-08823 Improper privilege management in SUSE Rancher CVSS 3.1CRITICAL 9.9
- TI-2022-21491 Rancher: Exposure of sensitive fields CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-22649 · CVE Program
- CVE-2023-22649 · NVD
- FIRST EPSS
- GHSA-xfj7-qf8w-2gcr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences