Open redirect in https://github.com/rails/rails
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
An open redirect vulnerability is fixed in Rails 7.0.4.1 with the new protection against open redirects from calling redirect_to with untrusted user input. In prior versions the developer was fully responsible for only providing trusted input. However the check introduced could allow an attacker to bypass with a carefully crafted URL resulting in an open redirect vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | https://github.com/rails/rails | 7.0.4.1 | — | No fix listed | CNA |
| — | actionpack (RubyGems) | 7.0.0 to before 7.0.4.1 | 7.0.4.1 | Patch available | GHSA-9445-4cr6-336r |
- https://github.com/rails/rails Vendor— Affected 7.0.4.1 Fixed in — No fix listed CNA
- actionpack (RubyGems) Vendor— Affected 7.0.0 to before 7.0.4.1 Fixed in 7.0.4.1 Patch available GHSA-9445-4cr6-336r
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:actionpack_project:actionpack:*:*:*:*:*:ruby:*:* | 7.0.0 to before 7.0.4.1 | Vulnerable | Actionpack Project |
| cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* | 7.0.0 to before 7.0.4.1 | Vulnerable | Rails |
- cpe:2.3:a:actionpack_project:actionpack:*:*:*:*:*:ruby:*:* Versions 7.0.0 to before 7.0.4.1 Vulnerable ·Actionpack Project
- cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* Versions 7.0.0 to before 7.0.4.1 Vulnerable ·Rails
Remediation
- Fix · GHSA-9445-4cr6-336r actionpack (RubyGems) Fixed in 7.0.4.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22797
- 2026-10-03 Alias added: GHSA-9445-4cr6-336r
References
Sources
- CVE-2023-22797 · CVE Program
- CVE-2023-22797 · NVD
- FIRST EPSS
- GHSA-9445-4cr6-336r · GitHub Advisory Database · CC BY 4.0
- CVE-2023-22797 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences