Apache Airflow JDBC Provider: RCE Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow JDBC Provider. Airflow JDBC Provider Connection’s [Connection URL] parameters had no restrictions, which made it possible to implement RCE attacks via different type JDBC drivers, obtain airflow server permission. This issue affects Apache Airflow JDBC Provider: before 4.0.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow JDBC Provider | before 4.0.0 | 4.0.0 | Patch available | CNA |
| — | apache-airflow-providers-jdbc (PyPI) | before 4.0.0 | 4.0.0 | Patch available | GHSA-mm87-c3x2-6f89 |
- Apache Airflow JDBC Provider VendorApache Affected before 4.0.0 Fixed in 4.0.0 Patch available CNA
- apache-airflow-providers-jdbc (PyPI) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-mm87-c3x2-6f89
Remediation
- Fix · CNA Apache Airflow JDBC Provider (Apache Software Foundation) Fixed in 4.0.0
- Fix · GHSA-mm87-c3x2-6f89 apache-airflow-providers-jdbc (PyPI) Fixed in 4.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22886
- 2026-10-03 Alias added: GHSA-mm87-c3x2-6f89
References
Sources
- CVE-2023-22886 · CVE Program
- CVE-2023-22886 · NVD
- FIRST EPSS
- GHSA-mm87-c3x2-6f89 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences