spotipy Path traversal vulnerability that may lead to type confusion in URI handling code
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Spotipy is a light weight Python library for the Spotify Web API. In versions prior to 2.22.1, if a malicious URI is passed to the library, the library can be tricked into performing an operation on a different API endpoint than intended. The code Spotipy uses to parse URIs and URLs allows an attacker to insert arbitrary characters into the path that is used for API requests. Because it is possible to include "..", an attacker can redirect for example a track lookup via spotifyApi.track() to an arbitrary API endpoint like playlists, but this is possible for other endpoints as well. The impact of this vulnerability depends heavily on what operations a client application performs when it handles a URI from a user and how it uses the responses it receives from the API. This issue is patched in version 2.22.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| spotipy-dev | spotipy | before 2.22.1 | 2.22.1 | Patch available | CNA |
| — | spotipy (PyPI) | before 2.22.1 | 2.22.1 | Patch available | GHSA-q764-g6fm-555v |
- spotipy Vendorspotipy-dev Affected before 2.22.1 Fixed in 2.22.1 Patch available CNA
- spotipy (PyPI) Vendor— Affected before 2.22.1 Fixed in 2.22.1 Patch available GHSA-q764-g6fm-555v
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:spotipy_project:spotipy:*:*:*:*:*:*:*:* | before 2.22.1 | Vulnerable | Spotipy Project |
- cpe:2.3:a:spotipy_project:spotipy:*:*:*:*:*:*:*:* Versions before 2.22.1 Vulnerable ·Spotipy Project
Remediation
- Fix · CNA spotipy (spotipy-dev) Fixed in 2.22.1
- Fix · GHSA-q764-g6fm-555v spotipy (PyPI) Fixed in 2.22.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-23608
- 2026-10-03 Alias added: GHSA-q764-g6fm-555v
- 2026-10-09 EPSS moved to the 50th–90th percentile
References
More spotipy-dev vulnerabilities
- TI-2025-30321 Spotipy repo vulnerable to secrets exfiltration via `pull_request_target` CVSS 3.1CRITICAL 9.1
- TI-2025-40566 Spotipy has a XSS vulnerability in OAuth callback server CVSS 3.1LOW 3.6
Sources
- CVE-2023-23608 · CVE Program
- CVE-2023-23608 · NVD
- FIRST EPSS
- GHSA-q764-g6fm-555v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences