Read the docs
TI-2023-09443 Aliases CVE-2023-23614

Improper session handling of "Remember me for 7 days" functionality

Priority HIGH 73CWE-613Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-613.

Summary

Pi-hole®'s Web interface (based off of AdminLTE) provides a central location to manage your Pi-hole. Versions 4.0 and above, prior to 5.18.3 are vulnerable to Insufficient Session Expiration. Improper use of admin WEBPASSWORD hash as "Remember me for 7 days" cookie value makes it possible for an attacker to "pass the hash" to login or reuse a theoretically expired "remember me" cookie. It also exposes the hash over the network and stores it unnecessarily in the browser. The cookie itself is set to expire after 7 days but its value will remain valid as long as the admin password doesn't change. If a cookie is leaked or compromised it could be used forever as long as the admin password is not changed. An attacker that obtained the password hash via an other attack vector (for example a path traversal vulnerability) could use it to login as the admin by setting the hash as the cookie value without the need to crack it to obtain the admin password (pass the hash). The hash is exposed over the network and in the browser where the cookie is transmitted and stored. This issue is patched in version 5.18.3.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0098 62nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Pi-holeAdminLTE<= 4.0, >= 5.18.3—No fix listedCNA
  • AdminLTE VendorPi-hole Affected <= 4.0, >= 5.18.3 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pi-hole:web_interface:*:*:*:*:*:*:*:*4.0 to before 5.18.3VulnerablePi-hole
  • cpe:2.3:a:pi-hole:web_interface:*:*:*:*:*:*:*:* Versions 4.0 to before 5.18.3 Vulnerable ·Pi-hole

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-23614

References

  • TI-2025-36756 Pi-hole Admin Interface vulnerable to HTTP response header injection via CRLF injection CVSS 3.1HIGH 8.2
  • TI-2026-25803 Pi-hole has a Stored HTML attribute injection CVSS 3.1MEDIUM 6.1
  • TI-2026-25801 Pi-hole has a Stored XSS / HTML injection in the Network page/Dashboard CVSS 3.1MEDIUM 6.1
  • TI-2026-25800 Pi-hole has a Reflected XSS / HTML injection in taillog.js CVSS 3.1MEDIUM 6.1
  • TI-2025-33477 Pi-hole Admin Interface vulnerable to cross-site scripting via malformed URL path on 404 error page CVSS 4.0MEDIUM 5.1
  • TI-2026-25802 Pi-hole has a Stored HTML Injection in queries.js CVSS 3.1MEDIUM 4.8
See all 15 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences