An issue was discovered in Nagios XI before 5.9.3.
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-208.
Summary
An issue was discovered in Nagios XI before 5.9.3. The is_insecure_login_authenticated function uses a insecure timing comparison that leads to an attacker being able to bruteforce the admin password, by measuring timing differences in the comparison.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Nagios XI (Nagios) Fixed in 5.9.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Nagios XI 5.9.3
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2023-09818 Open redirect in Nagios XIPriority LOW 18
Timeline
- 2026-10-02 Threatist record created from CVE-2023-24035
- 2026-10-03 Alias added: GHSA-4w2r-vx7w-6p4w
References
More Nagios vulnerabilities
- TI-2021-07545 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2021-07544 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2021-07543 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2019-11993 Nagios XI before 5.6.6 allows remote command execution as root. KEVCVSS 3.1HIGH 8.8
- TI-2023-26027 Nagios XI before version 5.11.3 was discovered to contain a remote code execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2021-15313 Nagios XI Switch Wizard before version 2.5.7 is vulnerable to remote code execution… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-24035 · CVE Program
- CVE-2023-24035 · NVD
- FIRST EPSS
- GHSA-4w2r-vx7w-6p4w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences