Cross-site request forgery in Jenkins Keycloak Authentication Plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability in Jenkins Keycloak Authentication Plugin 2.3.0 and earlier allows attackers to trick users into logging in to the attacker's account.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Keycloak Authentication Plugin | up to 2.3.0 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:keycloak (Maven) | before 2.3.1 | 2.3.1 | Patch available | GHSA-9wrr-4r9v-26xc |
- Jenkins Keycloak Authentication Plugin VendorJenkins Affected up to 2.3.0 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:keycloak (Maven) Vendor— Affected before 2.3.1 Fixed in 2.3.1 Patch available GHSA-9wrr-4r9v-26xc
Remediation
- Fix · GHSA-9wrr-4r9v-26xc org.jenkins-ci.plugins:keycloak (Maven) Fixed in 2.3.1 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Jenkins Keycloak Authentication Plugin unspecified
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2023-10078 Jenkins Keycloak Authentication Plugin 2.3.0 and earlier does not invalidate the previous session on login.Priority MEDIUM 51
Timeline
- 2026-10-02 Threatist record created from CVE-2023-24457
- 2026-10-03 Alias added: GHSA-9wrr-4r9v-26xc
References
More Jenkins Keycloak Authentication vulnerabilities
- TI-2023-10078 Jenkins Keycloak Authentication Plugin 2.3.0 and earlier does not invalidate the previous session on login. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-24457 · CVE Program
- CVE-2023-24457 · NVD
- FIRST EPSS
- GHSA-9wrr-4r9v-26xc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences