vBulletin before 5.6.9 PL1 allows an unauthenticated remote attacker to execute arbitrary…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-502.
Summary
vBulletin before 5.6.9 PL1 allows an unauthenticated remote attacker to execute arbitrary code via a crafted HTTP request that triggers deserialization. This occurs because verify_serialized checks that a value is serialized by calling unserialize and then checking for errors. The fixed versions are 5.6.7 PL1, 5.6.8 PL1, and 5.6.9 PL1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25135
- 2026-10-03 Alias added: GHSA-r8jw-f89q-p7g6
References
More Vbulletin vulnerabilities
- TI-2020-13248 vBulletin 5.5.4 through 5.6.2 allows remote command execution via crafted subWidgets data… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-12540 vBulletin 5.x through 5.5.4 allows remote command execution via the widgetConfig[code]… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-31014 vBulletin 5.0.0 through 5.7.5 and 6.0.0 through 6.0.3 allows unauthenticated users to… CVSS 3.1CRITICAL 10.0
- TI-2020-10114 vBulletin before 5.5.6pl1, 5.6.0 before 5.6.0pl1, and 5.6.1 before 5.6.1pl1 has incorrect access control. CVSS 3.1CRITICAL 9.8
- TI-2016-05317 SQL injection vulnerability in forumrunner/includes/moderation.php in vBulletin before… CVSS 3.0CRITICAL 9.8
- TI-2025-31015 Certain vBulletin versions might allow attackers to execute arbitrary PHP code by abusing… CVSS 3.1CRITICAL 9.0
Sources
- CVE-2023-25135 · CVE Program
- CVE-2023-25135 · NVD
- FIRST EPSS
- GHSA-r8jw-f89q-p7g6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences