Read the docs
TI-2023-10654 Aliases CVE-2023-25194GHSA-26f8-x7cc-wqpc

Deserialization of untrusted data in Apache Kafka Connect API

Priority HIGH 84CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 fixed, 1 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.

Summary

A possible security vulnerability has been identified in Apache Kafka Connect API. This requires access to a Kafka Connect worker, and the ability to create/modify connectors on it with an arbitrary Kafka client SASL JAAS config and a SASL-based security protocol, which has been possible on Kafka Connect clusters since Apache Kafka Connect 2.3.0. When configuring the connector via the Kafka Connect REST API, an authenticated operator can set the `sasl.jaas.config` property for any of the connector's Kafka clients to "com.sun.security.auth.module.JndiLoginModule", which can be done via the `producer.override.sasl.jaas.config`, `consumer.override.sasl.jaas.config`, or `admin.override.sasl.jaas.config` properties. This will allow the server to connect to the attacker's LDAP server and deserialize the LDAP response, which the attacker can use to execute java deserialization gadget chains on the Kafka connect server. Attacker can cause unrestricted deserialization of untrusted data (or) RCE vulnerability when there are gadgets in the classpath. Since Apache Kafka 3.0.0, users are allowed to specify these properties in connector configurations for Kafka Connect clusters running with out-of-the-box configurations. Before Apache Kafka 3.0.0, users may not specify these properties unless the Kafka Connect cluster has been reconfigured with a connector client override policy that permits them. Since Apache Kafka 3.4.0, we have added a system property ("-Dorg.apache.kafka.disallowed.login.modules") to disable the problematic login modules usage in SASL JAAS configuration. Also by default "com.sun.security.auth.module.JndiLoginModule" is disabled in Apache Kafka Connect 3.4.0. We advise the Kafka Connect users to validate connector configurations and only allow trusted JNDI configurations. Also examine connector dependencies for vulnerable versions and either upgrade their connectors, upgrading that specific dependency, or removing the connectors as options for remediation. Finally, in addition to leveraging the "org.apache.kafka.disallowed.login.modules" system property, Kafka Connect users can also implement their own connector client config override policy, which can be used to control which Kafka client properties can be overridden directly in a connector config and which cannot.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.9581 99th percentileScored 2026-11-07
Fix Partial Apache Kafka Connect API (Apache Software Foundation): 3.4.0org.apache.kafka:connect (Maven): 3.4.0Red Hat: 2 advisoriesRed Hat: 2 fixed, 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Kafka Connect API2.3.0 to before 3.4.03.4.0Patch availableCNA
—org.apache.kafka:connect (Maven)2.3.0 to before 3.4.03.4.0Patch availableGHSA-26f8-x7cc-wqpc
  • Apache Kafka Connect API VendorApache Affected 2.3.0 to before 3.4.0 Fixed in 3.4.0 Patch available CNA
  • org.apache.kafka:connect (Maven) Vendor— Affected 2.3.0 to before 3.4.0 Fixed in 3.4.0 Patch available GHSA-26f8-x7cc-wqpc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:kafka_connect:*:*:*:*:*:*:*:*2.3.0 – 3.3.2VulnerableApache
  • cpe:2.3:a:apache:kafka_connect:*:*:*:*:*:*:*:* Versions 2.3.0 – 3.3.2 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Kafka Connect API (Apache Software Foundation) Fixed in 3.4.0
  • Fix · GHSA-26f8-x7cc-wqpc org.apache.kafka:connect (Maven) Fixed in 3.4.0 Advisory →

Red Hat 2 advisories

  • RHSA-2023:3223 Released 2023-05-18 · Red Hat rating Important
    Red Hat AMQ Streams 2.4.0 release and security update
    • Red Hat AMQ Streams 2.4.0
  • RHSA-2023:1241 Released 2023-03-14 · Red Hat rating Moderate
    Red Hat AMQ Streams 2.2.1 release and security update
    • Red Hat AMQ Streams 2.2.1

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
streams for Apache KafkaAffectedNo fix yet
Red Hat AMQ Streams 2.2.1Fixed RHSA-2023:1241
Red Hat AMQ Streams 2.4.0Fixed RHSA-2023:3223
Not affected: 1 product
  • Red Hat build of Apicurio Registry 2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-25194
  2. 2026-10-03 Alias added: GHSA-26f8-x7cc-wqpc

References

Sources