Cross Site Scripting (XSS) Vulnerability in Fetlife rollout-ui version 0.5, allows…
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross Site Scripting (XSS) Vulnerability in Fetlife rollout-ui version 0.5, allows attackers to execute arbitrary code via a crafted url to the delete a feature functionality.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00521 44th percentileScored 2026-11-07
Fix Fixed rollout-ui (RubyGems): 0.5.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | rollout-ui (RubyGems) | before 0.5.3 | 0.5.3 | Patch available | GHSA-5xq9-h3j2-jxvc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- rollout-ui (RubyGems) Vendor— Affected before 0.5.3 Fixed in 0.5.3 Patch available GHSA-5xq9-h3j2-jxvc
Remediation
- Fix · GHSA-5xq9-h3j2-jxvc rollout-ui (RubyGems) Fixed in 0.5.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25309
- 2026-10-03 Alias added: GHSA-5xq9-h3j2-jxvc
References
Advisory 2
Other 5
- https://github.com/fetlife/rollout-ui/pull/15
- https://github.com/fetlife/rollout-ui/commit/713d9c2edd4d7b0d8c287bea960d3c6bd2c5b306
- https://github.com/fetlife/rollout-ui
- https://github.com/fetlife/rollout-ui/releases/tag/v0.5.3
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rollout-ui/CVE-2023-25309.yml
Sources
- CVE-2023-25309 · CVE Program
- CVE-2023-25309 · NVD
- FIRST EPSS
- GHSA-5xq9-h3j2-jxvc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences