HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Partial Red Hat: 7 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat.
Summary
HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:haproxy:haproxy:*:*:*:*:*:*:*:* | before 2.0.31; 2.1.0 to before 2.2.29; 2.3.0 to before 2.4.22; 2.5.0 to before 2.5.12; 2.6.0 to before 2.6.9; 2.7.0 to before 2.7.3 | Vulnerable | HAProxy |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:haproxy:haproxy:*:*:*:*:*:*:*:* Versions before 2.0.31; 2.1.0 to before 2.2.29; 2.3.0 to before 2.4.22; 2.5.0 to before 2.5.12; 2.6.0 to before 2.6.9; 2.7.0 to before 2.7.3 Vulnerable ·HAProxy
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
Red Hat 6 advisories
- RHSA-2024:0746 Released 2024-02-08 · Red Hat rating Importantnew container image: rhceph-5.3
- Red Hat Ceph Storage 5.3 Tools rhceph/rhceph-5-dashboard-rhel8, rhceph/rhceph-haproxy-rhel8
- RHSA-2023:1325 Released 2023-05-18 · Red Hat rating ImportantOpenShift Container Platform 4.13.0 security update
- Ironic content for Red Hat OpenShift Container Platform 4.13 python-werkzeug-2.0.3-4.el9, python3-werkzeug-2.0.3-4.el9
- Red Hat OpenShift Container Platform 4.13 buildah-1:1.29.1-1.rhaos4.13.el9, buildah-tests-1:1.29.1-1.rhaos4.13.el9, cri-o-1.26.3-3.rhaos4.13.git641290e.el9 +27
- RHSA-2023:1978 Released 2023-04-25 · Red Hat rating Moderatehaproxy security update
- Red Hat Enterprise Linux AppStream EUS (v.9.0) haproxy-2.4.7-2.el9_0.2
Show 3 more Red Hat advisories
- RHSA-2023:1655 Released 2023-04-12 · Red Hat rating CriticalOpenShift Container Platform 4.10.56 security update
- Red Hat OpenShift Container Platform 4.10 haproxy-2.2.19-4.el8, haproxy22-2.2.19-4.el8, jenkins-2-plugins-4.10.1680703106-1.el8 +5
- RHSA-2023:1696 Released 2023-04-11 · Red Hat rating Moderatehaproxy security update
- Red Hat Enterprise Linux AppStream (v. 9) haproxy-2.4.17-3.el9_1.2
- RHSA-2023:1268 Released 2023-03-21 · Red Hat rating ModerateOpenShift Container Platform 4.12.8 security update
- Red Hat OpenShift Container Platform 4.12 haproxy-2.2.24-3.rhaos4.12.el8, haproxy22-2.2.24-3.rhaos4.12.el8, openshift-4.12.0-202303132316.p0.geab9cc9.assembly.stream.el8 +3
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Out of support scope |
| Red Hat Ceph Storage 5.3 Tools | Fixed | RHSA-2024:0746 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:1696 |
| Red Hat Enterprise Linux AppStream EUS (v.9.0) | Fixed | RHSA-2023:1978 |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2023:1655 |
| Red Hat OpenShift Container Platform 4.11 | Fixed | — |
| Red Hat OpenShift Container Platform 4.12 | Fixed | RHSA-2023:1268 |
| Red Hat OpenShift Container Platform 4.13 | Fixed | RHSA-2023:1325 |
Not affected: 9 products
- Ironic content for Red Hat OpenShift Container Platform 4.13
- Red Hat Ceph Storage 5.3 Tools
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.11
- Red Hat OpenShift Container Platform 4.12
- Red Hat OpenShift Container Platform 4.13
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25725
- 2026-10-03 Alias added: GHSA-h2p2-w857-329f
References
Sources
- CVE-2023-25725 · CVE Program
- CVE-2023-25725 · NVD
- FIRST EPSS
- GHSA-h2p2-w857-329f · GitHub Advisory Database · CC BY 4.0
- CVE-2023-25725 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences