versionn Command Injection Vulnerability
Priority MEDIUM 52CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
versionn, software for changing version information across multiple files, has a command injection vulnerability in all versions prior to version 1.1.0. This issue is patched in version 1.1.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01584 75th percentileScored 2026-11-07
Fix Fixed versionn (commenthol): 1.1.0versionn (npm): 1.1.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| commenthol | versionn | before 1.1.0 | 1.1.0 | Patch available | CNA |
| — | versionn (npm) | before 1.1.0 | 1.1.0 | Patch available | GHSA-fj78-2vc5-f6cm |
- versionn Vendorcommenthol Affected before 1.1.0 Fixed in 1.1.0 Patch available CNA
- versionn (npm) Vendor— Affected before 1.1.0 Fixed in 1.1.0 Patch available GHSA-fj78-2vc5-f6cm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:versionn_project:versionn:*:*:*:*:*:*:*:* | before 1.1.0 | Vulnerable | Versionn Project |
- cpe:2.3:a:versionn_project:versionn:*:*:*:*:*:*:*:* Versions before 1.1.0 Vulnerable ·Versionn Project
Remediation
- Fix · CNA versionn (commenthol) Fixed in 1.1.0
- Fix · GHSA-fj78-2vc5-f6cm versionn (npm) Fixed in 1.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25805
- 2026-10-03 Alias added: GHSA-fj78-2vc5-f6cm
References
More commenthol vulnerabilities
- TI-2026-34191 md-fileserver: Stored/Reflected XSS when viewing Markdown (raw HTML allowed) CVSS 3.1HIGH 7.2
- TI-2019-12553 regular expressions Cross-Site Scripting (XSS) vulnerability in serialize-to-js CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-25805 · CVE Program
- CVE-2023-25805 · NVD
- FIRST EPSS
- GHSA-fj78-2vc5-f6cm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences