SQL Injection via replacements in sequelize
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Sequelize is a Node.js ORM tool. In versions prior to 6.19.1 a SQL injection exploit exists related to replacements. Parameters which are passed through replacements are not properly escaped which can lead to arbitrary SQL injection depending on the specific queries in use. The issue has been fixed in Sequelize 6.19.1. Users are advised to upgrade. Users unable to upgrade should not use the `replacements` and the `where` option in the same query.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| sequelize | sequelize | before 6.19.1 | 6.19.1 | Patch available | CNA |
| — | sequelize (npm) | before 6.19.1 | 6.19.1 | Patch available | GHSA-wrh9-cjv3-2hpw |
- sequelize Vendorsequelize Affected before 6.19.1 Fixed in 6.19.1 Patch available CNA
- sequelize (npm) Vendor— Affected before 6.19.1 Fixed in 6.19.1 Patch available GHSA-wrh9-cjv3-2hpw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* | before 6.19.1 | Vulnerable | Feathers-Sequalize |
- cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* Versions before 6.19.1 Vulnerable ·Feathers-Sequalize
Remediation
- Fix · CNA sequelize (sequelize) Fixed in 6.19.1
- Fix · GHSA-wrh9-cjv3-2hpw sequelize (npm) Fixed in 6.19.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25813
- 2026-10-03 Alias added: GHSA-wrh9-cjv3-2hpw
References
Exploit 2
More sequelize vulnerabilities
- TI-2026-48580 Sequelize: SQL Injection (Oracle DB) CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-25813 · CVE Program
- CVE-2023-25813 · NVD
- FIRST EPSS
- GHSA-wrh9-cjv3-2hpw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences