Improper authentication in Siemens Mendix SAML
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287.
Summary
A vulnerability has been identified in Mendix SAML (Mendix 7 compatible) (All versions >= V1.16.4 < V1.17.3), Mendix SAML (Mendix 8 compatible) (All versions >= V2.2.0 < V2.3.0), Mendix SAML (Mendix 9 latest compatible, New Track) (All versions >= V3.1.9 < V3.3.1), Mendix SAML (Mendix 9 latest compatible, Upgrade Track) (All versions >= V3.1.8 < V3.3.0), Mendix SAML (Mendix 9.6 compatible, New Track) (All versions >= V3.1.9 < V3.2.7), Mendix SAML (Mendix 9.6 compatible, Upgrade Track) (All versions >= V3.1.8 < V3.2.6). The affected versions of the module insufficiently verify the SAML assertions. This could allow unauthenticated remote attackers to bypass authentication and get access to the application. For compatibility reasons, fix versions still contain this issue, but only when the recommended, default configuration option `'Use Encryption'` is disabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Siemens | Mendix SAML (Mendix 7 compatible) | All versions >= V1.16.4 < V1.17.3 | — | No fix listed | CNA |
| Siemens | Mendix SAML (Mendix 8 compatible) | All versions >= V2.2.0 < V2.3.0 | — | No fix listed | CNA |
| Siemens | Mendix SAML (Mendix 9 latest compatible, New Track) | All versions >= V3.1.9 < V3.3.1 | — | No fix listed | CNA |
| Siemens | Mendix SAML (Mendix 9 latest compatible, Upgrade Track) | All versions >= V3.1.8 < V3.3.0 | — | No fix listed | CNA |
| Siemens | Mendix SAML (Mendix 9.6 compatible, New Track) | All versions >= V3.1.9 < V3.2.7 | — | No fix listed | CNA |
| Siemens | Mendix SAML (Mendix 9.6 compatible, Upgrade Track) | All versions >= V3.1.8 < V3.2.6 | — | No fix listed | CNA |
- Mendix SAML (Mendix 7 compatible) VendorSiemens Affected All versions >= V1.16.4 < V1.17.3 Fixed in — No fix listed CNA
- Mendix SAML (Mendix 8 compatible) VendorSiemens Affected All versions >= V2.2.0 < V2.3.0 Fixed in — No fix listed CNA
- Mendix SAML (Mendix 9 latest compatible, New Track) VendorSiemens Affected All versions >= V3.1.9 < V3.3.1 Fixed in — No fix listed CNA
- Mendix SAML (Mendix 9 latest compatible, Upgrade Track) VendorSiemens Affected All versions >= V3.1.8 < V3.3.0 Fixed in — No fix listed CNA
- Mendix SAML (Mendix 9.6 compatible, New Track) VendorSiemens Affected All versions >= V3.1.9 < V3.2.7 Fixed in — No fix listed CNA
- Mendix SAML (Mendix 9.6 compatible, Upgrade Track) VendorSiemens Affected All versions >= V3.1.8 < V3.2.6 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mendix:saml:*:*:*:*:*:mendix:*:* | 1.16.4 to before 1.17.2; 2.2.0 to before 2.2.3; 3.1.9 to before 3.2.5 | Vulnerable | Mendix |
- cpe:2.3:a:mendix:saml:*:*:*:*:*:mendix:*:* Versions 1.16.4 to before 1.17.2; 2.2.0 to before 2.2.3; 3.1.9 to before 3.2.5 Vulnerable ·Mendix
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25957
- 2026-10-03 Alias added: GHSA-q7cf-mx43-6qm5
References
More Siemens vulnerabilities
- TI-2026-20057 Authentication bypass in Fortinet FortiWeb KEVCVSS 3.1CRITICAL 9.4
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2025-18911 Heap-based buffer overflow in Fortinet FortiSwitchManager KEVCVSS 3.1CRITICAL 9.8
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2022-07142 Code injection in Spring Framework KEVCVSS 3.1CRITICAL 9.8
- TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
Sources
- CVE-2023-25957 · CVE Program
- CVE-2023-25957 · NVD
- FIRST EPSS
- GHSA-q7cf-mx43-6qm5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences