Prototype pollution in dottie
Priority HIGH 72CWE-1321Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Versions of the package dottie before 2.0.4 are vulnerable to Prototype Pollution due to insufficient checks, via the set() function and the current variable in the /dottie.js file.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01053 64th percentileScored 2026-11-07
Fix Fixed dottie: 2.0.4dottie (npm): 2.0.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | dottie | before 2.0.4 | 2.0.4 | Patch available | CNA |
| — | dottie (npm) | before 2.0.4 | 2.0.4 | Patch available | GHSA-4gxf-g5gf-22h4 |
- dottie Vendor— Affected before 2.0.4 Fixed in 2.0.4 Patch available CNA
- dottie (npm) Vendor— Affected before 2.0.4 Fixed in 2.0.4 Patch available GHSA-4gxf-g5gf-22h4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dottie_project:dottie:*:*:*:*:*:node.js:*:* | before 2.0.4 | Vulnerable | Dottie Project |
- cpe:2.3:a:dottie_project:dottie:*:*:*:*:*:node.js:*:* Versions before 2.0.4 Vulnerable ·Dottie Project
Remediation
- Fix · CNA dottie Fixed in 2.0.4
- Fix · GHSA-4gxf-g5gf-22h4 dottie (npm) Fixed in 2.0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-26132
- 2026-10-03 Alias added: GHSA-4gxf-g5gf-22h4
References
More Dottie Project Dottie vulnerabilities
- TI-2026-22188 Dottie vulnerable to prototype pollution bypass via non-first path segments in set() and transform() CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-26132 · CVE Program
- CVE-2023-26132 · NVD
- FIRST EPSS
- GHSA-4gxf-g5gf-22h4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences