Read the docs
TI-2023-11364 Aliases CVE-2023-26140GHSA-v7v8-gjv7-ffmr

Cross-site scripting in @excalidraw/excalidraw

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Versions of the package @excalidraw/excalidraw from 0.0.0 are vulnerable to Cross-site Scripting (XSS) via embedded links in whiteboard objects due to improper input sanitization.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00561 46th percentileScored 2026-11-07
Fix Fixed @excalidraw/excalidraw (npm): 0.15.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@excalidraw/excalidraw0.0.0 and later—No fix listedCNA
—@excalidraw/excalidraw (npm)before 0.15.30.15.3Patch availableGHSA-v7v8-gjv7-ffmr
  • @excalidraw/excalidraw Vendor— Affected 0.0.0 and later Fixed in — No fix listed CNA
  • @excalidraw/excalidraw (npm) Vendor— Affected before 0.15.3 Fixed in 0.15.3 Patch available GHSA-v7v8-gjv7-ffmr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:excalidraw:excalidraw:*:*:*:*:*:node.js:*:*all versionsVulnerableexcalidraw
  • cpe:2.3:a:excalidraw:excalidraw:*:*:*:*:*:node.js:*:* Versions all versions Vulnerable ·excalidraw

Remediation

  • Fix · GHSA-v7v8-gjv7-ffmr @excalidraw/excalidraw (npm) Fixed in 0.15.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-26140
  2. 2026-10-03 Alias added: GHSA-v7v8-gjv7-ffmr

References

Sources