strongSwan 5.9.8 and 5.9.9 potentially allows remote code execution because it uses a…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing, Denial of service
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-295 and CWE-476.
Summary
strongSwan 5.9.8 and 5.9.9 potentially allows remote code execution because it uses a variable named "public" for two different purposes within the same function. There is initially incorrect access control, later followed by an expired pointer dereference. One attack vector is sending an untrusted client certificate during EAP-TLS. A server is affected only if it loads plugins that implement TLS-based EAP methods (EAP-TLS, EAP-TTLS, EAP-PEAP, or EAP-TNC). This is fixed in 5.9.10.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | — | — | No fix listed | CNA |
- — Vendor— Affected — Fixed in — No fix listed CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:strongswan:strongswan:5.9.8:-:*:*:*:*:*:* | 5.9.8 | Vulnerable | strongSwan |
| cpe:2.3:a:strongswan:strongswan:5.9.9:-:*:*:*:*:*:* | 5.9.9 | Vulnerable | strongSwan |
- cpe:2.3:a:strongswan:strongswan:5.9.8:-:*:*:*:*:*:* Versions 5.9.8 Vulnerable ·strongSwan
- cpe:2.3:a:strongswan:strongswan:5.9.9:-:*:*:*:*:*:* Versions 5.9.9 Vulnerable ·strongSwan
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-26463
- 2026-10-03 Alias added: GHSA-vcx9-7pcc-q8c7
References
More Strongswan vulnerabilities
- TI-2023-22300 strongSwan before 5.9.12 has a buffer overflow and possible unauthenticated remote code… CVSS 3.1CRITICAL 9.8
- TI-2015-03374 strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon… CVSS 3.0CRITICAL 9.8
- TI-2004-00531 FreeS/WAN 1.x and 2.x, and other related products including superfreeswan 1.x, openswan… CVSS 2.0HIGH 10.0
- TI-2021-20414 In strongSwan before 5.9.5, a malicious responder can send an EAP-Success message too… CVSS 3.1CRITICAL 9.1
- TI-2017-08240 The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of… CVSS 3.1HIGH 7.5
- TI-2021-18520 The gmp plugin in strongSwan before 5.9.4 has a remote integer overflow via a crafted… CVSS 3.1HIGH 7.5
Sources
- CVE-2023-26463 · CVE Program
- CVE-2023-26463 · NVD
- FIRST EPSS
- GHSA-vcx9-7pcc-q8c7 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-26463 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences