Read the docs
TI-2023-11629 Aliases CVE-2023-26482

Scope of workflow operations is not validated in nextcloud server

Priority MEDIUM 48CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-78.

Summary

Nextcloud server is an open source home cloud implementation. In affected versions a missing scope validation allowed users to create workflows which are designed to be only available for administrators. Some workflows are designed to be RCE by invoking defined scripts, in order to generate PDFs, invoking webhooks or running scripts on the server. Due to this combination depending on the available apps the issue can result in a RCE at the end. It is recommended that the Nextcloud Server is upgraded to 24.0.10 or 25.0.4. Users unable to upgrade should disable app `workflow_scripts` and `workflow_pdf_converter` as a mitigation.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.04176 90th percentileScored 2026-11-07
Fix Fixed security-advisories (nextcloud): 24.0.10, 25.0.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
nextcloudsecurity-advisoriesbefore 24.0.10; 25.0.0 to before 25.0.424.0.10, 25.0.4Patch availableCNA
  • security-advisories Vendornextcloud Affected before 24.0.10; 25.0.0 to before 25.0.4 Fixed in 24.0.10, 25.0.4 Patch available CNA

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:*18.0.0 to before 20.0.14.12; 21.0.0 to before 21.0.9.10; 22.0.0 to before 22.2.10.10; 23.0.0 to before 23.0.12.5Vulnerablenextcloud
cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:*24.0.0 to before 24.0.10Vulnerablenextcloud
cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:*24.0.0 to before 24.0.10Vulnerablenextcloud
cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:*25.0.0 to before 25.0.4Vulnerablenextcloud
cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:*25.0.0 to before 25.0.4Vulnerablenextcloud
  • cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 18.0.0 to before 20.0.14.12; 21.0.0 to before 21.0.9.10; 22.0.0 to before 22.2.10.10; 23.0.0 to before 23.0.12.5 Vulnerable ·nextcloud
  • cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* Versions 24.0.0 to before 24.0.10 Vulnerable ·nextcloud
  • cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 24.0.0 to before 24.0.10 Vulnerable ·nextcloud
  • cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:-:*:*:* Versions 25.0.0 to before 25.0.4 Vulnerable ·nextcloud
  • cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 25.0.0 to before 25.0.4 Vulnerable ·nextcloud

Remediation

  • Fix · CNA security-advisories (nextcloud) Fixed in 24.0.10, 25.0.4

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-26482

References

  • TI-2023-20855 Users can delete external storage mount points CVSS 3.1HIGH 7.7
  • TI-2023-11091 Nextcloud download permissions can be changed by resharer CVSS 3.1HIGH 7.5
  • TI-2023-10624 Nextcloud Server vulnerable to SSRF via filter bypass due to lax checking on IPs CVSS 3.1MEDIUM 5.3
  • TI-2025-37238 Cross-site scripting in Nextcloud CVSS 3.1MEDIUM 6.4
  • TI-2023-11086 nextcloud vulnerable to Uncontrolled Resource Consumption CVSS 3.1MEDIUM 6.5
  • TI-2022-18738 Exception logging in Sharepoint app reveals clear-text connection details CVSS 3.1MEDIUM 6.5
See all 188 →

Sources