Read the docs
TI-2023-11736 Aliases CVE-2023-26604GHSA-8989-8fhv-vq42

systemd before 247 does not adequately block local privilege escalation for some Sudo…

Priority HIGH 69CWE-269Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat. Impact type from CWE-269.

Summary

systemd before 247 does not adequately block local privilege escalation for some Sudo configurations, e.g., plausible sudoers files in which the "systemctl status" command may be executed. Specifically, systemd does not set LESSSECURE to 1, and thus other programs may be launched from the less program. This presents a substantial security risk when running systemctl from Sudo, because less executes as root when the terminal size is too small to show the complete systemctl output.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01051 64th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Red Hat: 3 advisories

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
cpe:2.3:a:systemd_project:systemd:*:*:*:*:*:*:*:*before 246.7Vulnerablesystemd
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
  • cpe:2.3:a:systemd_project:systemd:*:*:*:*:*:*:*:* Versions before 246.7 Vulnerable ·systemd

Remediation

Red Hat 3 advisories

  • RHSA-2024:7705 Released 2024-10-07 · Red Hat rating Moderate
    systemd security update
    • Red Hat Enterprise Linux Server (v. 7 ELS) libgudev1-219-78.el7_9.11, libgudev1-219-78.el7_9.11.ppc, libgudev1-devel-219-78.el7_9.11 +8
    • Red Hat Enterprise Linux Server Optional (v. 7 ELS) systemd-journal-gateway-219-78.el7_9.11, systemd-networkd-219-78.el7_9.11, systemd-resolved-219-78.el7_9.11 +1
  • RHSA-2024:1105 Released 2024-03-05 · Red Hat rating Moderate
    systemd security update
    • Red Hat Enterprise Linux BaseOS EUS (v.8.6) systemd-239-58.el8_6.13, systemd-container-239-58.el8_6.13, systemd-devel-239-58.el8_6.13 +5
  • RHSA-2023:3837 Released 2023-06-27 · Red Hat rating Moderate
    systemd security and bug fix update
    • Red Hat Enterprise Linux BaseOS (v. 8) systemd-239-74.el8_8.2, systemd-container-239-74.el8_8.2, systemd-devel-239-74.el8_8.2 +5

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux BaseOS (v. 8)Fixed RHSA-2023:3837
Red Hat Enterprise Linux BaseOS EUS (v.8.6)Fixed RHSA-2024:1105
Red Hat Enterprise Linux Server (v. 7 ELS)Fixed RHSA-2024:7705
Red Hat Enterprise Linux Server Optional (v. 7 ELS)Fixed RHSA-2024:7705
Not affected: 1 product
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-26604
  2. 2026-10-03 Alias added: GHSA-8989-8fhv-vq42

References

Sources