Unchecked fieldpath index in Composition's patches can lead to arbitrary memory allocation in crossplane
Key facts
- Attack vector
- Adjacent network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
crossplane-runtime is a set of go libraries used to build Kubernetes controllers in Crossplane and its related stacks. In affected versions an already highly privileged user able to create or update Compositions can specify an arbitrarily high index in a patch's `ToFieldPath`, which could lead to excessive memory usage once such Composition is selected for a Composite resource. Compositions allow users to specify patches inserting elements into arrays at an arbitrary index. When a Composition is selected for a Composite Resource, patches are evaluated and if a specified index is greater than the current size of the target slice, Crossplane will grow that slice up to the specified index, which could lead to an excessive amount of memory usage and therefore the Pod being OOM-Killed. The index is already capped to the maximum value for a uint32 (4294967295) when parsed, but that is still an unnecessarily large value. This issue has been addressed in versions 1.11.2, 1.10.3, and 1.9.2. Users are advised to upgrade. Users unable to upgrade can restrict write privileges on Compositions to only admin users as a workaround.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| crossplane | crossplane | before 1.9.2; 1.10.0 to before 1.10.3; 1.11.0 to before 1.11.2 | 1.9.2, 1.10.3, 1.11.2 | Patch available | CNA |
| — | github.com/crossplane/crossplane (Go) | before 1.9.2 | 1.9.2 | Patch available | GHSA-v829-x6hh-cqfq |
| — | github.com/crossplane/crossplane (Go) | 1.10.0 to before 1.10.3 | 1.10.3 | Patch available | GHSA-v829-x6hh-cqfq |
| — | github.com/crossplane/crossplane (Go) | 1.11.0 to before 1.11.2 | 1.11.2 | Patch available | GHSA-v829-x6hh-cqfq |
- crossplane Vendorcrossplane Affected before 1.9.2; 1.10.0 to before 1.10.3; 1.11.0 to before 1.11.2 Fixed in 1.9.2, 1.10.3, 1.11.2 Patch available CNA
- github.com/crossplane/crossplane (Go) Vendor— Affected before 1.9.2 Fixed in 1.9.2 Patch available GHSA-v829-x6hh-cqfq
- github.com/crossplane/crossplane (Go) Vendor— Affected 1.10.0 to before 1.10.3 Fixed in 1.10.3 Patch available GHSA-v829-x6hh-cqfq
- github.com/crossplane/crossplane (Go) Vendor— Affected 1.11.0 to before 1.11.2 Fixed in 1.11.2 Patch available GHSA-v829-x6hh-cqfq
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:crossplane:crossplane:*:*:*:*:*:*:*:* | 1.9.0 to before 1.9.2; 1.10.0 to before 1.10.3; 1.11.0 to before 1.11.2 | Vulnerable | crossplane |
- cpe:2.3:a:crossplane:crossplane:*:*:*:*:*:*:*:* Versions 1.9.0 to before 1.9.2; 1.10.0 to before 1.10.3; 1.11.0 to before 1.11.2 Vulnerable ·crossplane
Remediation
- Fix · CNA crossplane (crossplane) Fixed in 1.9.2, 1.10.3, 1.11.2
- Fix · GHSA-v829-x6hh-cqfq github.com/crossplane/crossplane (Go) Fixed in 1.9.2 Advisory →
- Fix · GHSA-v829-x6hh-cqfq github.com/crossplane/crossplane (Go) Fixed in 1.10.3 Advisory →
- Fix · GHSA-v829-x6hh-cqfq github.com/crossplane/crossplane (Go) Fixed in 1.11.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27484
- 2026-10-03 Alias added: GHSA-v829-x6hh-cqfq
References
Sources
- CVE-2023-27484 · CVE Program
- CVE-2023-27484 · NVD
- FIRST EPSS
- GHSA-v829-x6hh-cqfq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences