Insufficient authorization validation between zones when xCAT zones are enabled
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
xCAT is a toolkit for deployment and administration of computer clusters. In versions prior to 2.16.5 if zones are configured as a mechanism to secure clusters in XCAT, it is possible for a local root user from one node to obtain credentials to SSH to any node in any zone, except the management node of the default zone. XCAT zones are not enabled by default. Only users that use the optional zone feature are impacted. All versions of xCAT prior to xCAT 2.16.5 are vulnerable. This problem has been fixed in xCAT 2.16.5. Users making use of zones should upgrade to 2.16.5. Users unable to upgrade may mitigate the issue by disabling zones or patching the management node with the fix contained in commit `85149c37f49`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| xcat2 | xcat-core | before 2.16.5 | 2.16.5 | Patch available | CNA |
- xcat-core Vendorxcat2 Affected before 2.16.5 Fixed in 2.16.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:xcat_project:xcat:*:*:*:*:*:*:*:* | before 2.16.5 | Vulnerable | Xcat Project |
- cpe:2.3:a:xcat_project:xcat:*:*:*:*:*:*:*:* Versions before 2.16.5 Vulnerable ·Xcat Project
Remediation
- Fix · CNA xcat-core (xcat2) Fixed in 2.16.5
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27486
References
Sources
- CVE-2023-27486 · CVE Program
- CVE-2023-27486 · NVD
- FIRST EPSS
- CVE-2023-27486 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences