Galaxy vulnerable to unauthorized modification of pages/visualizations due to insufficient permission check
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-284.
Summary
Galaxy is an open-source platform for data analysis. All supported versions of Galaxy are affected prior to 22.01, 22.05, and 23.0 are affected by an insufficient permission check. Unsupported versions are likely affected as far back as the functionality of Visualizations/Pages exists. Due to this issue, an attacker can modify or delete any Galaxy Visualization or Galaxy Page given they know the encoded ID of it. Additionally, they can copy or import any Galaxy Visualization given they know the encoded ID of it. Patches are available for versions 22.01, 22.05, and 23.0. For the changes to take effect, you must restart all Galaxy server processes. There are no supported workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| galaxyproject | galaxy | before 22.01 | 22.01 | Patch available | CNA |
- galaxy Vendorgalaxyproject Affected before 22.01 Fixed in 22.01 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:galaxyproject:galaxy:*:*:*:*:*:*:*:* | before 22.01 | Vulnerable | galaxyproject |
- cpe:2.3:a:galaxyproject:galaxy:*:*:*:*:*:*:*:* Versions before 22.01 Vulnerable ·galaxyproject
Remediation
- Fix · CNA galaxy (galaxyproject) Fixed in 22.01
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27578
References
More galaxyproject Galaxy vulnerabilities
- TI-2023-22903 Galaxy vulnerable to Server Side Request Forgery during data imports CVSS 3.1MEDIUM 6.3
- TI-2022-07530 Arbitrary file access in the Galaxy data analysis platform CVSS 3.1HIGH 8.6
- TI-2015-07990 galaxy-data-resource Command Line Template injection CVSS 3.1CRITICAL 9.8
- TI-2024-28338 Possible Data Tampering & Loss of Public Datasets in Galaxy CVSS 3.1CRITICAL 9.1
- TI-2024-28333 Stored Cross Site Scripting (Stored XSS) in Galaxy CVSS 3.1HIGH 7.6
- TI-2018-15916 The Galaxy Project Galaxy version v14.10 contains a CWE-79: Improper Neutralization of… CVSS 3.0MEDIUM 6.1
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences